LinkStar-H68K-0232 Router Firmware Updates

I bought the wired version. I am hugely disappointed that a lot was promised (for example, running Ubuntu) but very little supplied, and support is sketchy.

Also the tools to flash to emmc only are supplied for windows.

I would return it for my money back if it wasn’t such a huge hassle.

1 Like

I flashed openwrt to eMMC yesterday. I did struggle with the online instructions as they were not great. However, it does seem more stable now which is good news.


Hey Paul, glad it worked out. They added a lot of functionality t the available snapshot they created, but I found I had to add a bit more. A few things I might suggest you do or look for along the way:

  1. Change up the defaults (always change the password) and configure to your needs.
  2. Harden the router for security (plenty of content in the OpenWrt forum and wiki on that).
  3. Run an opkg update from the command line or software update from Luci and install any new packages you need.
  4. The luci-app-uhttpd package will faciltate with the hardening process. After install, check the Redirect all HTTP to HTTPS box and click Save & Apply.
  5. Know that if you install adblock and luci-app-adblock, the Luci interface will not work correctly so you will need to configure from the command line
  6. Know that for banip, there is no Luci interface package available in the available repositories (luci-app-banip is not available). Again you will need to configure from the command line.
  7. The Argon theme that is preinstalled is cool. You will find that installing the luci-app-argon-config package to be very cool if you want to tweak it.
  8. The preinstalled NAS - Samba works out of the box. Depending on who accesses, you you may want to to configure shares and passwords for your users.
  9. SQM works awesome and keep the bufferbloat down, but remember you’ll need to tune it to work properly.

For the Luci UI issues above, it sure would be great if someone from Seeed Studio would:

  • Respond to any of these…
  • Let us know when the next release will be
  • Set up their fork of ImmortalWRT with a build-bot or Github repo to auto-build snapshots like most maintainers of an OpenWrt software fork do
  • Worked with the OpenWrt community to provide their code back upstream or made some pull-requests so they can support this device - as advertised…

Bueller? Bueller? Anyone from Seeed Studio that can give us an update?


Hey Ron, Excellent I will make the changes :slight_smile:


1 Like

I also got the wi-fi version a couple days ago and I am also disappointed with this Ubuntu/Debian Linux BS. Tried flashing similar rockchip linux images to no success. Hopefully that changes soon. I recommend putting the OpenWRT image on eMMC, changing your WAN port to one of the 2.5gb ports instead, changing wifi frequencies to get a better signal, and utilizing docker for plex. Keep me posted if there’s a discord or something useful for adding Linux.


Hi, I would be interested to know how you get on with plex. I was thinking of adding it and maybe migrating my home assistant into it.

Maybe we can start our on discord channel or I’m happy to open my one up to everyone.



I’d love to join it!

1 Like


I’ve created a channel called H68K and then under this for android, ubuntu, openwrt etc to get us started. Please free to request more and I can add them. Discord invite is

thanks paul

1 Like

OK, it has now been nearly a month, and FINALLY…there’s a download available for Ubuntu! Unfortunately, it doesn’t seem to be very useful. Any idea how to actually get into any of the settings? I can click on either “Settings” or “Display Settings”, however all it does is spin for a short while, then do nothing. Also, many of the included apps fail to load. Note that this is the 4GB RAM model, and I have allowed it to automatically update everything (once installed). Still no difference.

1 Like

Hey @gadgethome I use a docker container to run my plex media server. Quite easy to do and theres lots of videos on it. I decided to return the h68k. I’m glad they finally put a ubuntu image up and running. But I kinda figured it was gonna be half-assed and under developed just to stop bad reviews about the H68K’s linux false advertising.
I really do like the specs and design of this product, but it needs to be fully functionally with its price point. I’m now waiting for another device that I’ve seen videos of it actually performing linux with ease & i might revisit the H68K on its 3rd rendition when it’s not a dud. Good luck on your discord.

1 Like

Hi @sda thanks for the post and sorry to see you go. I’ll give docker a go and see how I get on.


1 Like

would love to know what device you’re lookin’ at!

@BigRon - ImmortalWRT is designed for MAINLAND China users. Of course, the Chinese Communist Party requires all routers sold to MAINLAND China users in 2023 to have backdoors and so these devices are obviously going to be somewhat locked down from running arbitrary binaries. To be fair to SeeedStudio, they’re based in China and have to follow the laws of China.

The simple solution for flashing an image to eMMC without Windows and the customized Rockchip dev tools

  1. Follow directions to get OpenWRT on TF card Install Operating System - Seeed Wiki
  2. Place the TF card in and boot into OpenWRT
  3. Connect *nix machine to the LinkStar ETH2 port
  4. Run from local terminal dd if=<openwrt_image.img> | ssh root@ "dd of=/dev/mmcblk0"
  5. Power it off
  6. Take out the TF card
  7. Power on
  • If you are using a machine without dd command like on Windows you can SCP the file to the LinkStar and run dd if=<openwrt_image.img> of=/dev/mmcblk0 command from a SSH shell.

I’ve tried VMWare fusion and VirtualBox with several version versions of Windows running the RockChip dev tools and all would fail or corrupt just the eMMC. Building the RockChip dev tool from GitHub and flashing the image through command line did not work either.

I have OpenWRT flashed to eMMC of the LinkStar and I can definitely attest to the speed and stability of a WISP setup. The connection is very stable even at a significant distance from WiFi router. Under constant load it remains stable.

I originally setup FriendlyElec NanoPi R4S for this purpose, but the USB Wifi dongle support sucks. With just a AP configured after the first client disconnects from the AP the entire interface would crash and require a reboot.

Hello @uncommon. Unfortunately at this time, it does not yet appear anyone is building or updating a firmware image or update for the H68K - Immortal, OpenWRT, or otherwise.

Hello @AvertEuphemism. Thanks for the response. I had no issues with flashing to eMMC whereas some others on this forum did. Looks like you found what is an easier way. My challenge is getting access to firmware image updates. Let me know if you found a source.

According to the response on the product page 3mo ago, they will be releasing the OpenWRT source code, but gave no timeframe. Looks like they’re just one stable version behind. The latest stable OpenWRT 22.03 was released less than a month ago.

I dug around the sourceforge and it looks like they have been focused on the ubuntu distro.

I’ve been trying to get openwrt installed without success. I download the image and flash it to an SD card (tried several). I boot the router and find that pings. But ssh to the router is unsuccessful, no surprise since nmap reveals all ports are closed. Erp.

1 Like

You should see a solid green light. If you do trying plugging in a HDMI cable and my hunch is that you’ll see the Android TV GUI. My suspicion is that there is a problem with your SD card. I had issues with my SD cards until I repartitioned and reformatted it before trying to burn the image onto the SD card.