LinkStar-H68K-0232 Router Firmware Updates

Thanks for the input. Without the card I see Android TV GUI; with it the screen is blank. I’ve tried different SD cards I have (which in the past have booted Raspberry PIs, so they’re OK.)

Did you use balenaEtcher to write the image? What did you format the card as?

No, I wrote it using dd:

sudo dd if=image file of=/dev/mmcblk0

works great on Pi’s.

Thanks for the input.

Just to double-check:

  1. I installed Balena Etcher
  2. used it to write the downloaded file
  3. boot
  4. get blinking green, then steady light
  5. hdmi port is blank, shows nothing pings, but nmap shows ports are closed.

Hello @yawlhoo, not sure if you did this already… Assuming the OpenWrt install was successful, you would attach an ethernet cable from your laptop/desktop to Eth1, 2, or 3, of the LinkStar. Then log into the admin console from your browser at: (NOTE you are referencing in your earlier post).

Account name: root
Password: password

Good luck.

Thanks for your input.

I tried on eth2. Nothing there; that ip doesn’t ping, either; nmap reports it is not up.

BTW, the md5sum of the downloaded openwrt file checks out

I am having an issue trying to flash OpenWRT to the LinkStar-H68K Wi-Fi model. I am using the RKDevTool to try and flash the firmware but get Download Boot Fail when trying to flash the LinkStar-H68K-EraseFlash.img to get started. Any ideas?

EDIT: After restarting my Windows Computer I was able to successfully flash the Erase Image.


The wiki did mention that some high speed TF cards do not work with it. Although I have several class 10 high speed high capacity TF cards and they all work. I originally had issues with my TF cards too. I also previously used the card with Pi Zero W, but issue was resolved after I formatted it to erased the exfat MBR with diskutility on macOS. I notice that the openwrt image have about 32mb empty space in the beginning and in between the 2 partitions. Maybe flashing the image it doesn’t overwrite something in the beginning of the card where the boot sector is supposed to be.

1 Like

Following your advice I took a card, erased it, and formatted it to fat32. Using Balena Etcher I wrote the openwrt image. This time was there, and my browser opened the login page.

So, all is well, thanks for your help.


Excellent glad you got it working.

1 Like

Thanks. Not to introduce a sour note, but I bought this as a possible replacement for my Edgerouter. But I am not willing to rely on this as a main component of my system, given that the image download is offered as a one-off, there doesn’t seem to be a maintained, updated repository.

1 Like

The OpenWRT code was just released

1 Like

Waal shut my mouth! (grin)

1 Like

This is great news! Has anyone tested this build on their H68K? If so, would love to know more about the experience. Thanks!

Like with any application build, environment setup and keeping things updated to match the application requirements is always a pain. I would suggest doing the build inside a docker container. I have not tried out this particular Dockerfile build yet, but looks promising

1 Like

I checked out this docker build system, and I find this a little too complicated for me. Never envisioned having to build my own Openwrt images when I bought my router!

1 Like

It’s not that complicated. Spin up the container, pull in the code and run a few commands. I takes some effort, but less effort and a lot cheaper than a sidewinder.

1 Like

I don’t think this should fall to each individual user. Seeedstudio should have someone maintaining up-to-date builds, bug fixes, etc. if they expect people to buy their routers for production uses.

1 Like

I’m pretty sure that it’s not a one off. Anyways the code is only one major version behind. For most users it’s not that big of a deal as long as the system is stable and no major vulnerabilities in the core. The code would eventually make it back into the main branch and be apart of the OpenWRT builds. The structure of the OpenWRT project is setup to support many different hardware/vendors. I think due to the bureaucracy of getting things merged into the main line slows down things so they went ahead and did a build for the early adopters. Since they released the source anyone knowledgable dev could take point on creating and getting a PR to merge into the main OpenWRT repo.

Looking at the OpenWRT and the lack of unit tests, and petty bickering in the PR comments for much of the packages do not make me feel safe running OpenWRT directly connected to the internet. I would only trust using OpenWRT as a portable device powered on infrequently or on a device behind something like edgerouter or pfsense after digging into things like f2fs, and travelmate issues. I am not confident in the work done on those.

The packages and system processes are made up of many scripts that does a bunch of string parsing and are error prone. When I was setting up travel mate I noticed it kept crashing when I did a scan and apparently it doesn’t parse stations with WPA2-PSK/WPA3-SAE encryption enabled.

Another thing I have 2 H68K I restored the settings from one to the other and apparently the MAC address remained the same in the /etc/config/wireless due to the restore. Boy did that cause me headaches trying to diagnose why the one device that was working flawlessly for may weeks started freezing up. I would expect it to discard packets that doesn’t belong to it, but for some reason it took down the entire device instead of just the NIC disconnecting.

1 Like

Looks like they’re working on getting it into standard OpenWRT, just that they’ve only really just released the hardware. My impression of SeeedStudio is that their hardware is generally solid, but it’s for people who are comfortable messing around with soldering irons and/or compilers, so I can imagine they’ve released this when it’s barely ready, rather than waiting a year behind closed doors while they perfect the software.

Following along on the build instructions on the first page of their repository it all seems to build pretty straightforwardly, and I have managed to install it onto the eMMC by dd’ing an image on their which was built from the defaults of their OpenWRT tree (I first copied their standard image onto an SDcard and booted that, then I was able to connect to that and upload the image file I had built).

Now I’m working on building a more functional version of OpenWRT, because of course it’s usually for very lightweight devices. It at least helps that I have been using OpenWRT as my router OS of choice for close to 20 years, even if I’ve not actually built it from source previously.