Ubuntu on Linkstar-K68K

Hey Tripp. We are all blazing a trail here with this new device and the things that can be done with it. Some of these things may “brick” your device, as in it remains useless and unbootable from that point forward, (or if you are lucky, need to jump through a lot of hoops to recover). That being said, know the risks you take while trying these things out. The first key question is, why do you want Ubuntu installed? What use case or every day life problems are you trying to solve? If you are good with the answers, then proceed but know there are risks involved and they are yours to assume, not me or anyone else’s.

In premise however, this should work. The advantage of running it on a bootable Flash Card or USB would be to test if and how Ubuntu (or any other Linux flavor) works on it. If it does not, dismount or shut down and reboot the device, no harm done. Assuming the it is working properly, it would sense alternate drive on the device and at the same time will allow you to install directly from the bootable Flash Card or USB. If you are familiar with Ubuntu you should be familiar with this. Also, make sure you have a key board, mouse, and monitor hooked up, preferably wired (not wireless), and working on the Android software it shipped with. This way you do not have to worry about wireless drivers flaking out on you during your initial tests.

Although I would take the route I outlined above, there are plenty of examples similar out there like running Ubuntu on a Raspberry Pi, and the LinksStar-H68K is a lot more powerful and has the specs to handle it. For a similar use-case with installation on a Raspberry Pi, see below:

Do your homework. Good luck and let me what you decide and if it works.

Thanks for the great response and the details.

My primary goal of running a linux OS is to run PFSense and portainer so I can run some of the tools I want to like PiHole among other things. The reason I want Ubuntu is it was the selling point SeedStudio used to cause me to buy it and their documentation is sadly lacking right now.

So setting up Ubuntu isn’t the issue it’s getting it running on the LinkStar that is an unknown to me and like you mentioned I don’t want to brick my new toy. On my Pi I’m using the RPi memory card imager so you click click click and you have a working/usable Pi. For the LinkStar Google has no useful links for this install specifically (just points back to SeedStudio which says “coming soon”).

I’ll take a look at the guide for the Pi you linked to and try it out when I get back home from a trip next week.

1 Like

Hey! Having the same issue. Would really like to stick ubuntu on this thing, but no glory. Tried via sd card and sideloading via devtool as described. If anyone has any luck please share!

Forward progress! They released an img for Ubuntu - Install Operating System - Seeed Wiki

It works and their instructions to install worked, ish. I haven’t played with it too much but immediately I found an issue with the networking. Only hardware eth0 and eth1 work. Eth2 and eth3 and wlan0 don’t show up in ‘ifconfig’ command so I haven’t been able to make wireless work. I’ve reached out to support to ask for some assistance.

I followed the (thankfully very detailed) installation instructions on the Wiki. (Thanks for the great docs.) Installing OpenWRT on SD was super easy… Installing it on eMMC was easy enough (other than needing to dust off a Windows machine) but didn’t work! It rebooted like it said it would in the docs, but it’s not listening on, and there are no activity lights on the LEDs when I reboot. I can reboot with the SD card installed, and it will boot, but booting off of eMMC is going to be way more reliable, and I don’t want to get the whole configuration set up and then have to redo it once I get eMMC working.

What can I do to diagnose what’s wrong? Re-flashing it is quite a pain with the ancient windows machine, but it just being DOA with Ubuntu on it is kind of sad. :frowning:

Let me know how to get this working to spec!

Super cool box. I just wish it came in a 5gbps version too!


I flashed Ubuntu onto the eMMC without issue. It did seem to take a few hard boot cycles to come alive but now boots normally.

Interesting! I’ll try hard booting it a few more times…

Are there any activity lights on the device when it boots? That was one noticeable difference between the working boot cycle with the microSD, and the non-working boot cycle with the flashed OS. In the microSD working case, the lights blink. In the eMMC non-working case, they do not.

And just to confirm, the correct image to instal lis openwrt-rockchip-R22.11.18_opc-h68k-d-squashfs-sysupgrade.img, yes? (Interestingly when I try to open this image through a disk image mounting tool, it says it’s corrupted, but the flash installer reported success installing it.)

1 Like

Confirmed. openwrt-rockchip-R22.11.18_opc-h68k-d-squashfs-sysupgrade.img is the correct image. Although an image update or access to a Git repo for new images would be nice…

1 Like

Thank you for the confirmation!

I am thinking I should just build the img myself from source, so I know I have a valid img file. But the code tab on Sourceforge (https://git.code.sf.net/p/linkstar-h68k-os/code) seems to be empty. Can someone at Seeed point us to a git repo?


1 Like

hello, we don’t develop source code, so that repository is not valid

I tried re-erasing the flash, and re-flashing the same image. This time the install still said it was ok, but the device didn’t reboot. It also showed it still in maskrom mode. I waited a while and then unplugged it (from USB-C. Power cable was never connected.) When it came back up it was still in Maskrom mode. (The first install it rebooted, but still didn’t come up in OpenWRT.)

How can I troubleshoot this? Is it a hardware problem?

Regarding the source code, I don’t mind that Seeed doesn’t have it in Sourceforge, but since it’s based on a GPL codebase, shouldn’t the OS be available to us? Doesn’t have to be from Sourceforge, but wherever?

I’ve reinstalled a third time and will leave it connected for a good long while to see if it reboots, but since it didn’t last time, I’m thinking it may not.

Also, a note for your wiki: On en_US Windows, the buttons you show in Chinese are properly localized into English, so you may want to put a windows box into en_US and make new images for the docs. That said, it’s useful having the zh_CN version there in case someone does it on an unsupported locale and gets the buttons in Chinese.

I attempted re-flashing the device a few times now… And still the same behavior: It never leaves Maskrom mode, and doesn’t reboot/won’t boot off the eMMC.

I’m a little disappointed not to have heard anything back from Seeed after two weeks.

Also disappointing that it ships with kind of a broken Android build on it by default. Why not just ship it with OpenWRT as the default OS? Does anyone actually want to run that Android clone OS on it?

Agreed on all accounts. Have the same challenge on my end with no response from anyone at Seeed regarding an updated OpenWrt image.

The eMMC is just a flash storage device like any block device. You can manipulate it like any device with parted, fdisk, or dd commands. If you boot from TF then ssh into the OpenWRT instance you will see a /dev/mmcblk0. You can manipulate it as you wish without fear of bricking the device. Imagine it as another TF card or hard drive. I’ve repartitioned and dd different images to the eMMC and was able to recover just fine. From my tests and observations the device is just a PC or raspberryPi. From their documentation the boot order is TF then eMMC; so that means if you screw up the eMMC you can still boot from the TF card.

I’ve documented the way to flash OpenWRT to eMMC without Windows and Rockchip dev tools.

I was an avid PiHole user, but after finding out about AdGuardHome I never looked back.Deployment is easy since it consists of a single binary. Since it is written in golang it supports many hardware platforms. I’ve deployed it to RaspberryPi, Ubiquiti Routers, Asuswrt-Merlin Routers, OpenWRT, and containerize.

I have multiple instances at different locations so this sync is awesome.

Hi, just to let everyone know, we already have ubuntu support, but this is a beta version and we will continue to make updates and the stable version will be released in March.


We’re in April now, what is the status of the Ubuntu release? I feel a bit duped for buying this for Ubuntu and you have yet to release a fully featured update.

I am also struggling with properly flashing an OS. I followed the steps to flash ubuntu. I am able to boot the K68 to a login screen. I cannot get past the login screen because I can’t figure out the password.

I tried flashing the openwrt image to the K68 but the K68 does not boot after flashing. It appears other people have the same issue here. Are there any updates on the ubuntu login?

I was able to install Lubuntu and log in:

default Username: linkstar, Password: linkstar
Root Username: root, Root Password: root
(from the “Install Operating System” page linked above by Seeed-Liu)

However, only eth0 and eth1 are available. Neither the 2.5G (eth2 and eth3) nor the wifi seems to be available. I upgraded to Ubuntu 22.04.2 LTS and upgraded all software packages as much as possible, but it’s still using a 4.19.219 kernel.

The wifi appears to need kernel version 5.12 or newer, according to MediaTek MT7921 802.11ax PCI Express Wireless Network Adapter

The 2.5G Ethernet appears to need kernel version 5.4 or newer, according to Realtek RTL 8125 - LinuxReviews