LinkStar-H68K-0232 Router Firmware Updates

OK, it has now been nearly a month, and FINALLY…there’s a download available for Ubuntu! Unfortunately, it doesn’t seem to be very useful. Any idea how to actually get into any of the settings? I can click on either “Settings” or “Display Settings”, however all it does is spin for a short while, then do nothing. Also, many of the included apps fail to load. Note that this is the 4GB RAM model, and I have allowed it to automatically update everything (once installed). Still no difference.

1 Like

Hey @gadgethome I use a docker container to run my plex media server. Quite easy to do and theres lots of videos on it. I decided to return the h68k. I’m glad they finally put a ubuntu image up and running. But I kinda figured it was gonna be half-assed and under developed just to stop bad reviews about the H68K’s linux false advertising.
I really do like the specs and design of this product, but it needs to be fully functionally with its price point. I’m now waiting for another device that I’ve seen videos of it actually performing linux with ease & i might revisit the H68K on its 3rd rendition when it’s not a dud. Good luck on your discord.

1 Like

Hi @sda thanks for the post and sorry to see you go. I’ll give docker a go and see how I get on.


1 Like

would love to know what device you’re lookin’ at!

@BigRon - ImmortalWRT is designed for MAINLAND China users. Of course, the Chinese Communist Party requires all routers sold to MAINLAND China users in 2023 to have backdoors and so these devices are obviously going to be somewhat locked down from running arbitrary binaries. To be fair to SeeedStudio, they’re based in China and have to follow the laws of China.

The simple solution for flashing an image to eMMC without Windows and the customized Rockchip dev tools

  1. Follow directions to get OpenWRT on TF card Install Operating System - Seeed Wiki
  2. Place the TF card in and boot into OpenWRT
  3. Connect *nix machine to the LinkStar ETH2 port
  4. Run from local terminal dd if=<openwrt_image.img> | ssh root@ "dd of=/dev/mmcblk0"
  5. Power it off
  6. Take out the TF card
  7. Power on
  • If you are using a machine without dd command like on Windows you can SCP the file to the LinkStar and run dd if=<openwrt_image.img> of=/dev/mmcblk0 command from a SSH shell.

I’ve tried VMWare fusion and VirtualBox with several version versions of Windows running the RockChip dev tools and all would fail or corrupt just the eMMC. Building the RockChip dev tool from GitHub and flashing the image through command line did not work either.

I have OpenWRT flashed to eMMC of the LinkStar and I can definitely attest to the speed and stability of a WISP setup. The connection is very stable even at a significant distance from WiFi router. Under constant load it remains stable.

I originally setup FriendlyElec NanoPi R4S for this purpose, but the USB Wifi dongle support sucks. With just a AP configured after the first client disconnects from the AP the entire interface would crash and require a reboot.

Hello @uncommon. Unfortunately at this time, it does not yet appear anyone is building or updating a firmware image or update for the H68K - Immortal, OpenWRT, or otherwise.

Hello @AvertEuphemism. Thanks for the response. I had no issues with flashing to eMMC whereas some others on this forum did. Looks like you found what is an easier way. My challenge is getting access to firmware image updates. Let me know if you found a source.

According to the response on the product page 3mo ago, they will be releasing the OpenWRT source code, but gave no timeframe. Looks like they’re just one stable version behind. The latest stable OpenWRT 22.03 was released less than a month ago.

I dug around the sourceforge and it looks like they have been focused on the ubuntu distro.

I’ve been trying to get openwrt installed without success. I download the image and flash it to an SD card (tried several). I boot the router and find that pings. But ssh to the router is unsuccessful, no surprise since nmap reveals all ports are closed. Erp.

1 Like

You should see a solid green light. If you do trying plugging in a HDMI cable and my hunch is that you’ll see the Android TV GUI. My suspicion is that there is a problem with your SD card. I had issues with my SD cards until I repartitioned and reformatted it before trying to burn the image onto the SD card.

Thanks for the input. Without the card I see Android TV GUI; with it the screen is blank. I’ve tried different SD cards I have (which in the past have booted Raspberry PIs, so they’re OK.)

Did you use balenaEtcher to write the image? What did you format the card as?

No, I wrote it using dd:

sudo dd if=image file of=/dev/mmcblk0

works great on Pi’s.

Thanks for the input.

Just to double-check:

  1. I installed Balena Etcher
  2. used it to write the downloaded file
  3. boot
  4. get blinking green, then steady light
  5. hdmi port is blank, shows nothing pings, but nmap shows ports are closed.

Hello @yawlhoo, not sure if you did this already… Assuming the OpenWrt install was successful, you would attach an ethernet cable from your laptop/desktop to Eth1, 2, or 3, of the LinkStar. Then log into the admin console from your browser at: (NOTE you are referencing in your earlier post).

Account name: root
Password: password

Good luck.

Thanks for your input.

I tried on eth2. Nothing there; that ip doesn’t ping, either; nmap reports it is not up.

BTW, the md5sum of the downloaded openwrt file checks out

I am having an issue trying to flash OpenWRT to the LinkStar-H68K Wi-Fi model. I am using the RKDevTool to try and flash the firmware but get Download Boot Fail when trying to flash the LinkStar-H68K-EraseFlash.img to get started. Any ideas?

EDIT: After restarting my Windows Computer I was able to successfully flash the Erase Image.


The wiki did mention that some high speed TF cards do not work with it. Although I have several class 10 high speed high capacity TF cards and they all work. I originally had issues with my TF cards too. I also previously used the card with Pi Zero W, but issue was resolved after I formatted it to erased the exfat MBR with diskutility on macOS. I notice that the openwrt image have about 32mb empty space in the beginning and in between the 2 partitions. Maybe flashing the image it doesn’t overwrite something in the beginning of the card where the boot sector is supposed to be.

1 Like