XIAO, Reset doesn't work anymore!

I accidentally shorted 5V and GND contacts

After it my MacBook wrote the following message:
Usb Accessories disabled
Unplug the accessory using too much power to re-enable USB devices.

I can’t reset XIAO anymore and there is no XIAO in the ports list in Arduino IDE or in VS Code + PlatformIO!
The light does not come on when I short the reset contacts!

How do I fix this? I broke my microcontroller?

Please tell us about your situation.
1.Can other USB devices be successfully connected to the USB port of the PC?
2.Will XIAO get hot?
3.Does the green LED on XIAO light up?
4.Specifically, how did you short-circuit which 5V and which GND?
5.Is 5V supplied from both the USB connector and the VCC pin as shown in the picture?


  1. yes, other usb devices can be connected
  2. XIAO has stable temperature
  3. Yes, the green LED near GND
  4. It was a short time. Something may have happened after uploading the sketch. I read on the internet that connecting of 5V and GND shouldn’t harm microcontroller
  5. Yes, electricity comes from VCC, pins work

Previously, I had to reset XIAO before each new upload of a sketch, because Arduino IDE doesn’t see XIAO after new uploads and you need to reset XIAO before uploading. Now I can’t upload a sketch because reset stopped to work

When power is supplied from USB, it is not necessary to supply from the VCC pin. Why not try disconnecting the power supply connected to the VCC pin?

I use USB to power the XIAO and VCC as output to power other components from XIAO

USB can only supply up to 500mA, does the PC output a message even if the parts connected to VCC are removed?

No, only if I connect VCC with GND I get a message on Mac:

Usb Accessories disabled
Unplug the accessory using too much power to re-enable USB devices.

Could this damage the bootloader? Or maybe a bug, I saw many people had same problem before me

Let me ask you questions again.
If you connect “ONLY” XIAO to USB, the PC will not output a message, right?
What is GRN?

If I connect only to USB I won’t got this message

Sorry, GND, I wrote it wrong

What do you connect the VCC pin to and what do you connect the GND pin to?
Is it possible that something you connect to is broken?

First connect only XIAO and USB. Does the orange LED blink slowly after double reset? Double reset is not easy to succeed. Please repeat it many times.
If the orange LED does not blink slowly, the bootloader may be corrupted.

I have a Oled 128*64 screen and an LED.
I might have connected something wrong.

Orange LED does not work, if I do reset. Only the power-LED works.
There is no damage on the XIAO and it did not heat up. It looks completely like new

I’m sure 100% the bootloader is corrupted

Confirm again.
Did you do a “double reset” instead of a “reset”?
A tool is required to rewrite the bootloader. The link below will be helpful.

Yes, of course I tried “double reset” many times.

Thanks for help, I will try to unbrick it with ST-LINK!

I also encountered this problem,and my pc cannot obtain the corresponding port ,I hope it will be helpful
sc 2022-09-24 105653

If your XIAO bootloader is broken and you have another unbricked XIAO, the following link may be helpful.

Hello, after I had this problem, I tried to unblock XIAO with ST-LINK and it works!

Just use this guide:
(But before you need to buy ST-LINK, its not expensive)

My XIAO is also resurrection after this ,I’m glad to see this post