XIAO esp32c3 Unknown USB Device (Device Descriptor Request Failed)

I reflashed the firmware with reference to the following URL, and now the esp32c3 is not recognized by Windows PC.

The device does not show up in Ports in device manager.

Unknown USB Device (Device Descriptor Request Failed) is displayed in Universal Serial Bus Controllers of Device Manager

Performing uninstallation of the device and connecting it to the PC again does not change the situation.

The same problem is observed when connecting to other Windows PC.

Is this broken?
Please let me know if there is any way to investigate.

Best regards.

Have you tried re-swapping the firmware after flashing it? The device will be unrecognized after flashing and will be recognized after plugging and unplugging.

What exactly is re-swapping?
I have plugged in and out after flushing, but every time I plug in I get an error “Unknown USB Device (Device Descriptor Request Failed)”.
I can’t even flash it again because it is not in Ports in Device Manager ;-(

Do you have another computer that can try to see if the device can be recognised again? We have reconfirmed the Wiki steps and the firmware and it is perfectly fine, did you flash the firmware for the wrong chip and cause the product to crash?

The reason the COM port did not show up in Ports in Device Manager was because I made a mistake when I connected the USB. (I did not hold down the Boot button).
I flashed the Firmware (ESP32-C3_RFTest_108_2b9b157_20211014.bin) again using EspRFTestTool_v2.8_Manual.exe, but the situation remains the same.

When I plug it into another PC, the message “Unknown USB Device (Device Descriptor Request Failed)” is displayed.

Based on your description, it looks like your steps and content are in order. I would suggest that you contact our technical support email to ask if there is a way to help you get a new XIAO or another solution.

Thank you.
I will contact technical support.

@ tgp: I encountered the same issue. I wonder if you were able to resolve it via technical support.

Same issue. Sort of kicking myself for even trying to flash the bootloader, but I have another one still. Didn’t really need to do this, but wanted to check that the bootloader flashing process worked as presented in the wiki page, in case I ever really needed to. Followed the instructions and the flashing process worked perfectly, except that now the device isn’t recognized by USB. I’ve re-flashed it several more times successfully. Tried uninstalling the faulting USB device. but when I connect the device to USB again, Windows 10 pops up “Device Not Recognized”. The device manager shows “Unknown USB Device (Device Descriptor Request Failed)”. For now, it’s bricked.

The ESP32 has a direct USB interface, so I don’t know what other device driver I could install that would cause it to be recognized. Obviously the firmware that is being listed for restoring the bootloader is not the same firmware the device ships with from factory. I wonder if there are any fuses that get flipped in the ESP32 that aren’t set by the bootloader and need to be done with a program? Debugger?

Anyone have a suggestion? Thanks,

Hi again. I just figured out the solution…
After re-flashing the bootloader successfully using the ESPRFTestTool, restart the ESP32C3 and enter the bootloader again (hold boot button, press reset button briefly, then release boot button). This will successfully connect to USB with a COM port in bootloader mode. Then go to your Arduino IDE and load a program (any) while hanging out in the bootloader. This will download your custom program. Then you can simply reset the device with the reset button and the program will run. Now when you power up by plugging the device into a USB port, it will be recognized as a COM port. They left this step out of the bootloader flashing instructions.


I have a similar problem. New board, uploaded first sketch ok but then gave a port error in the error window. Device manager shows unknown usb device (device descriptor request failed). Something I did notice (I initially put it down the ide being crap)… I selected the board and the port option showed as com6 (esp dev-board). ie/ it didnt say the specific board like a qtpy does. Dunno if it’s relavent.

first of all push and keep the boot button(in xiao esp32c3), then connect the usb cable to the pc.

1 Like

Thank you very much!
This solved my problems.

I’ve had the same problem. So, I’ve tried to reflash with the factory firmware as the document.

But, there was some wrong point. The old bin file is linked.

  • ESP32-C3_RFTest_108_2b9b157_20211014.bin

the flash tool, ESP_RF_Test_EN_0 have the latest version firmware.

  • ESP32-C3_RFTEST_V116_4cfb81d_20230922.bin

Please check the version of firmware!
With 20230922.bin, I’m good.

I can tell you what worked for me, what i did was this disabled USB selective suspend settings.

worked for me. Thank you! (at first not because I pressed the buttons in the wrong order)