Seeeduino Xiao USB port stopped being recognized by windows 10

I uploaded several sketch using arduino IDE on Seeeduino Xiao without problem but when I wanted to upload another sketch it failed and the reason is the usb port is not appear neither in arduino nor Windows device manager.
I’m using windows 10. any idea?

One idea (beware of other reasons as well):

=> Delete the failing COM-Port assignment and let it reassign by Windows:

Run Device Manager from elevated command line:

> devmgmt.msc

Enable “Show hidden devices” in the menu, and uninstall grayed-out COM ports.


1 Like

Hi Juergs
Sorry for late answer, my problem was that I was defined several pins were not existed pin 32, etc.
But I found the Seeeduino xia is very unreliable, for uploading the sketch I have spend a lot of energy, sometimes it works sometimes it doesn’t.

Sometimes it’s because of problems with the sketch you uploaded last time.Affects USB functionality.You can try bootloader mode by two resets .


It doesn’t work anymore, double tap of reset take it to boot loader mode(orange led) but no USB detected, I tried to upload boot loader using Stlink I had, but no success, another board I have started to change as well, first day uploaded sketch without any problem, now needed reset, probably the same thing, I switched back to ESP32 until some one find a solution for this problem. Thanks for the help.

I’ve been having a similar if not the same issue.
The Arduino editor loses connection to the port. I’d have to unplug the XIAO then plug it in again for it to be recognized. After doing this on and off for a few days the XIAO can no longer be recognized through another XIAO still works fine.
The bad XIAO still comes to life when I plug it in, but I can no longer upload programs to it.
I’m going to test it to see if I can upload a program through the SPI pins.

I’m sorry but that’s just nonsense. Clearly a defect with the design of the Xiao, as the issue is reported all over the place.

1 Like

short the reset ports twice

I just started to use my Xiao SamD (or at least trying to).

  • I plugged in the board as received from Seeeduino.

  • I programmed a demo for an LCD.

  • Immediately after the download succeeded windows popped up with a message something like " the last device connected in not recognized by windows" (Win 11 pro).

  • What’s funny is the popup would occur every 10 seconds or so. I’ve never seen such an action from Windows.

  • I then deleted the grayed out com port, the Xiao board was again recognized, I double shorted the reset and got into the boot (orange) mode.

  • Programmed the board with the “blink without delay” example.

  • Went right back to cannot recognize.

Is there a cure for this or do I just scrap these boards?



I am still trying to bottom this issue out, because I’m not sure its directly the Xiao. I have 6 pc’s onsite all running Arduino IDE V2.1.0. 2 program the Xiao without problems (no need to double-reset) the other 4 program just once then cannot see the usb port properly (USB not recognised from windows). The working PC’s are Windows 10 & Windows 11

Hi there,
You may want to go into the device manager and remove old port assignments, whenever I had port issues and wacky recognizing USB issues, that fixed it after a remove and reboot.
My .0 2
GL :slight_smile:

I first deinstalled all the Port as mentioned earlier.
This didnt help by itself.

I found this hint in a forum which worked for me:
“first of all push and keep the boot button(in xiao esp32c3), then connect the usb cable to the pc.”

XIAO esp32c3 Unknown USB Device (Device Descriptor Request Failed) - Products & Technology / Arduino & Seeeduino - Seeed Forum (