Unable to setup ReSpeaker on Raspberry Pi 4B

Hi all,

I’m having problems with operating the ReSpeaker on the Raspberry Pi Model 4B with a ReSpeaker 4-Mic Linear Array Kit. The operating system is Raspberry Pi Legacy released on 2022/04/04, and the connection is shown below. I’ve also tried it on a Raspberry Pi OS before, but it still fails so I tried using a different version for testing. I’ve followed the steps on the seeed wiki, but somehow it still won’t connect to the microphone. When typing arecord -L on the terminal, I get the following output message, which is different from what is shown on the page.

pi@raspberrypi:~/tdoa/mic_array/seeed-voicecard $ arecord -L
default
Playback/recording through the PulseAudio sound server
null
Discard all samples (playback) or generate zero samples (capture)
jack
JACK Audio Connection Kit
pulse
PulseAudio Sound Server
usbstream:CARD=b1
bcm2835 HDMI 1
USB Stream Output
usbstream:CARD=Headphones
bcm2835 Headphones
USB Stream Output

Is there anyone with similar issues or any ideas on solving the connection error?

Thanks in advance!

Hi Jaen,

Did you find the solution to address the above-mentioned issue?