Seeed Silence: What Is Going On?

It has been a while Seeed is silent.

Some facts:

  • No news from the Seeed Rangers program -see Is the Seeed Ranger program still alive?
  • Call for support are not answered.
  • The latest new products come from WaveShare -is a merger under way?
  • Direct messages I sent to Seeed board members remain unanswered.
  • Twitter activity from Seeed is now very limited.

I don’t want to speculate, but what is going on?

Thank you for your answer.

1 Like

And again there is a very loud and earie silence coming from @Seeed.

Sorry guys I think I am done with them and will move back to a normal Arduino. Those have never ever bricked on me.

Feel free to join this conversation at Twitter.

@erin.linke (Seeed US Head) - not responding to email or phone calls? Something seems very wrong here.

Hi, I’m Mario from Seeed US, How may I help you?

Also tons and tons of items out of stock. Are we about to see the disappearance of Seeed? Right after I buy boxes of Xiaos?

No answer from my usual contacts at Seeed I wrote to through LinkedIn.

As a member of the Seeed Ranger initiative, I was expecting to get some hardware samples to review them, provide feedback and post some projects based on them, as I did for the Xiao board and extensions.

Really strange indeed.

Hi @reivilo, this is Lily from Seeed Community Team. thank you for your feedback and we’re deeply sorry for this unpleasant experience. As there is personnel adjustment in our Community Department, which is in charge of running the Ranger Program, it led to the late responses accordingly. We sincerely apologize for not communicating and updating the program timely. For your request regarding to the Ranger Program, feel free to connect with me on LinkedIn or email me at lily.li(at)seeed.cc. Thank you again for your support. Have a nice day.

Hi @lily.li, Thank you for your answer. I sent you a message via LinkedIn.

I just got my re-terminal after about 3 months of waiting despite pre-ordering before the initial release and being charged that instant with the same generic response to each new availability date that passed. I take the day off of work to work with it, no intructions whatsoever. Plugged in and powered on jut like any new rpi boot of which ive done countless. Input the initial settings and finally jut like with any raspios first boot there is an auto-update followed by a reboot. Updated, turned off, never turned back on. I cant find anyone who knows anything. No tech support. The links are broken. Cant find a single instruction on the website or wiki for simple faqs. I considered everal times over these months buying the components piecemeal on amazon as they were all available and cheaper, but i really liked the case and portability of the design. If i waited 3 months for an instant brick, i will walk away from seeed, which ive also had problems such as receiving waveshare products. Older product models than advertised. and 2 falsely advertised rpi4bs off amazon at a premium for the guarantee they were current year models. They were clear refurbs of the oldest release. Soldering was poor, color and insignia were off. Usb ports required pliers to spread them open enough to fit a plug. solder composition was poor, stuff i use on electrical components and anchors for grounding shields. Anything involving precise or data transfer i use high purity silver solder as do official boards. Side not ive upgraded all my systems from buster to bullseye and all are stable except the seeed units. My business is failing due to these setbacks and my investors are walking. This company has amazing ideas, and everytime i say “i wish someone was making this” seed has it or is about to have it. Ive had my 8gb compute module to upgrade my terminal for 2 months. I dont dare open the case and try it less i void some capacity for refund should this be dead. Ive tried hooking up to hdmi, power comes on, nothing more. tried a factory reset, nothing. tried putting in an sd card with raspios already installed, nothing.