Please enter the encryption key for mmwave_kit

Hello, need some help.
I connected mmWave to my WLAN, installed ESPhome add on in HA.
When i add the discovered device be clicking configure, window pops up Do you want to add the ESPHome node mmwave_kit to Home Assistant? I click Submit, then i get this message
“Please enter the encryption key for mmwave_kit. You can find it in the ESPHome Dashboard or in your device configuration.”
Where do i find that?
I am using Home Assistant Yellow hub updated with latest latest HA 2023.9.2, supervisor.
EspHome is ver 2023.8.3
Where do i find encryption key, or configure to bypass?

1 Like

Sorry can’t help, I struggle with that as well and now can’t remember where I got the key.

Bought one of the new mmwave sensors which is supposedly a 2 min setup in home assistant, and here I am 6hrs later still struggling. The video and documentation are incorrect it seems, and it runs so fast it took me several attempts to just get it to pause at the right spot to see what it was doing.

Rant over, sorry, its just I specifically purchased this mmwave kit because it said no finding required and a 2min setup, and a bit annoyed that it is in fact the opposite. All I have is an esphome device.detexted with an entity called firmware update!

Hi guys, is it possible to provide any screenshots regarding this issue? We tried to redeploy and did not encounter this issue, what process did you follow to do this?

Is it possible to reflash the firmware for mmWave Human Detection Sensor Kit SKU 110061541 and I can try and run through the install process again ?

Agree 100%, NOT a 2 minute setup. That is false. I am going on 5 hours -still not connected…
About ready to request a refund.

Today i went into the web ui for ESPhome, found a encryption key which did not work per the screen shot.
I followed the instructions per the setup .

Today i tried a 2nd mmwave_kit that was purchased at same time. Same issue as before. Something in my HA yellow or esphome?
Please help.

It’s a pity seed support isn’t as fast as their instruction videos.

  1. Slow down your instruction videos, they are impossible to follow and must be running 6x normal speed.
  2. Speed up your support, between this thread and an email support I am trying to work through, I get 1 email per day asking me questions but not giving any actual response to my queries.

2 minute setup with no coding?

I am on day 3 now, and not even a glimpse of a presence sensor in ha!

Sorry we checked this issue, it may be that the wrong firmware was flashed during factory production, we repackaged the relevant firmware, please try to follow the guide to re-flash the firmware for it

User Craig Dye here.

I put another 4 hours into trying to get mmwave_kit working, no joy yet but closer. Here are recent steps.
I saw in the install video for this product the ESPHOME page in HA looked different then my installation. Not the same icons, also it could only be accessed in the card on the Add on page. So i uninstalled ESPHOME and reinstalled it. To do that, i went to the integration to bring it in from the store. The install went to the web UI and installed with Yaml window. Then i added the mmwave_kit and this time it said it installed with the finish window. No incription key needed, i thought Great.
Not so much, there is no card for mmwave_kit on the dash board or in devices under setup. It only shows in ESPHOME on the web UI as a device that is inactive.
Here is a log from installation.

INFO ESPHome 2023.8.3
INFO Reading configuration /config/esphome/mmwave-kit.yaml…
INFO Starting log output from mmwave-kit.local using esphome API
WARNING Can’t connect to ESPHome API for mmwave-kit.local: Error resolving IP address: [Errno -5] No address associated with hostname (APIConnectionError)
INFO Trying to connect to mmwave-kit.local in the background
We have urgently created this page today to be able to help users who are experiencing problems with the firmware to quickly resolve them.

I did the firmware update and it seems to have installed ok. I then wlan and password but there is not a card for mmwave_kit.
I have hard rebooted the device, searched for it, nothing. What now?

Please check all the devices displayed by your router and see if you can find the IP address of mmwave_kit?
mmWave Human Detection Sensor Kit | Seeed Studio Wiki — 毫米波人体检测传感器套件 |看工作室维基
In the meantime, we’ve updated the method for adding new firmware to ESPHome

I got the ip address from router, followed instructions to add in ESPHome, which looked to install correct. But still no mmwave_kit card in ESPhome.
ESPHOME does show 1 device in its card. Drilling into that i found a spot to install in Esphome. Did that and got this log.

INFO ESPHome 2023.9.0
INFO Reading configuration /config/esphome/seeedstudio-mmwave-kit-aaa8f8.yaml…
Failed config

esphome: None
name: seeedstudio-mmwave-kit-aaa8f8
friendly_name: SeeedStudio mmWave Kit aaa8f8
name_add_mac_suffix: False
name: seeedstudio.mmwave_kit
version: 1.1
board_build.flash_mode: dio
board_build.mcu: esp32c3

Could not find file '/config/esphome/../headers/mr24hpc1_mmwave_kit.h'. Please make sure it exists (full path: /config/headers/mr24hpc1_mmwave_kit.h).
- ../headers/mr24hpc1_mmwave_kit.h

build_path: build/seeedstudio-mmwave-kit-aaa8f8

I am thinking something is off. Just going in circles here.

Have you been able to get past this error? I’m stuck at the same place. My sensor has been added to ESPHome in Home Assistant, but fails when trying to install it with the same error:

Could not find file ‘/config/esphome/…/headers/mr24hpc1_mmwave_kit.h’. Please make sure it exists (full path: /config/headers/mr24hpc1_mmwave_kit.h).

I’m getting similar errors to others here. I have successfully flashed the device with the new firmware and added it to Home Assistant. But ESPHome shows it needs an update:

Installed version

Latest version

When I try to run the update, I get:

INFO ESPHome 2023.9.1
INFO Reading configuration /config/esphome/seeedstudio-mmwave-kit-aa9290.yaml…
Failed config

esphome: None
name: seeedstudio-mmwave-kit-aa9290
friendly_name: mmWave_Seeed_Kit
name_add_mac_suffix: False
name: seeedstudio.mmwave_kit
version: 1.1
board_build.flash_mode: dio
board_build.mcu: esp32c3

Could not find file '/config/esphome/../headers/mr24hpc1_mmwave_kit.h'. Please make sure it exists (full path: /config/headers/mr24hpc1_mmwave_kit.h).
- ../headers/mr24hpc1_mmwave_kit.h

build_path: build/seeedstudio-mmwave-kit-aa9290

I have not Keith.
I am waiting for a reply from Seeedstudio.
I have done 2 firmware updates and mmwave_kit and 2nd one got past the encryption issue but not finding files, same error as you.
I would like to see a step by step to install Esphome by Seeedstudio so that we can eliminate that variable. I say that because of the online UI seams to have the options to install where in HA did not have same install tools.
I am using Home Assistant Yellow.

I have esphome installed in Home Assistant for some other devices which are working fine, so I don’t think esphome is the issue. It just seems there’s a file from Seeedstudio missing that won’t allow it to be configured in Home Assistant.

I’m also using Home Assistant Yellow.

I’m not using a Home Assistant yellow, but I am running on a RasPi 4, so same architecture.

I suspect that seeedstudio-mmwave-kit-aa9290.yaml is pointing to the file in the wrong location.

From the ESPHome 9.0 Release notes:

The /config/esphome/.esphome folder has been removed and replaced with /data when running ESPHome as a Home Assistant add-on. This was done because it is exactly what the add-on /data folder was made for and there were many files in the .esphome folder that were making the Home Assistant Backup larger for no reason at all. All files in there are generated or sourced from online based on your configurations files which have not been touched.

So this:
/config/esphome/…/headers/mr24hpc1_mmwave_kit.h (from the error we’re getting)

Should be:

I don’t have a fix. I’m not a developer. That’s just what I believe may be happening here.

The reason for this error may be related to your attempt to make other configuration changes. You can download the sensor library to your Home Assistant by following this tutorial.