Odyssey X86 - Defective FAN

Hi everyone,

Just received my Odyssey X86, ordered from Amazon (Europe) with the emmc module and fan.
Everything seems to be working fine but I noticed the FAN doesn’t turn on.
Put the system under load and even with the temperature at 75º, no FAN.

Going closer I can hear a “clicking” noise coming from the FAN, like it’s trying to turn on.

On the BIOS I changed the Fan Control to positive, which will give 20% more PWM.
Now I can get the FAN turning when the CPU is > 60ºC, according to the documentation it’s 100% PWM !
Lower than 60º I hear the same clicking noise.

Defective FAN ? No idea on how to proceed now. Should I return the product? What a bummer…

Thanks.

Hi, can you share the OS version you tested for future analyses ? Which tools you used to monitor the temperature?

Tested with the installed windows 10 enterprise (64GB emmc) and used CPU-Z and HWMonitor to stress the CPU and to monitor the temps.

Bios: SD-BS-CJ41G-M-101-E x64
4.0.15.1303
02.04.03
13.0.1018

Odyssey fan controled by Embead controller (EC) which role as initialize the device before system up. The temperatre you saw in bios is detected by EC and the tempertaure sensor place close to the intel CPU which donot have the senser pin. In another word, the temperature not the CPU direct value, maybe 5 degrees centigrade error. What you saw the temperature value in pfsense or others system is feedback by CPU internal, temperature in BIOS screen feedback by EC, fan run or stop according the EC value.
EC detect value (BIOS screen) and fan speed table like this:

mode: Disable, fan state: stop

mode: Normal, fan state: less than 40°C–stop,45-50°C–50%,50-60℃–60%,above 60℃–80%

mode: Positive, fan state: less than 40°C–stop,45-50°C–70%,50-60℃–80%,above 60℃–100%

I appreciate and understand that the fan on this SBC is controlled by an embedded controller and temperature sensor other than what is built in to the main CPU chip. That is a reasonable engineering choice made by the SBC designer. However, it does not seem to be working very well. I too put this SBC through the same stress test and it got quite warm. The fan remained quiet. In the BIOS the fan speed shown is highly erratic and unpredictable. When the SBC is warm the fan speed reported in the BIOS will jump around erratically from zero to over 9,000 RPM back and forth in seconds. The fan is not doing that - it’s just what is reported on the BIOS screen.

For the record, mine has the 64GB eMMC and came with Windows 10 installed. I activated the installation with a legally obtained Windows 10 Pro code.

I am experiencing the same thing. 2 week old unit, still under testing with PFSense. Using the temperature monitoring screen within PFSense. Under load, using stress-ng, I can get temps to show as high as 74C, and fan does not turn ON. Have tried both options in BIOS.

Using a temp gun, heatsink is showing about 55C temperature. Trying to find out if this is normal and at what temperature (according to PFSense) should the fan turn ON.

Thanks

I just received my X86 within the last week or two, and I have noticed the exact same thing. I’ve never heard this fan turn on once, and I’ve seen temps up ~185 deg F (85 deg C) using OpenHardwareMonitor. Again I understand that the sensor may not be directly in the CPU that controls the fan, but come on, at some point someone has to acknowledge that there seems to be an issue here…

I ordered my X86 off of Amazon recently, and it was the board only with the 64GB eMMC and windows activated. I also ordered the re_case separately and have the board mounted in it.

I finally just got around to checking the Bios and after finding this forum, I’ve gone ahead and changed the fan control setting to “positive” to see if that makes any difference, although when I was poking around in there, I did find under H/W Monitor that it was reading the temp and said N/A for the fan, so not sure if that is N/A because it wasn’t running or if it is N/A as in it doesn’t recognize that there’s a fan…

I’ve also tried unplugging and plugging the fan pin connector, etc.

I’ll be pretty disappointed if I have to return this board just because the fan isn’t working as I haven’t been able to find anything close to a replacement part, which would be preferable at this point…

Edit: After booting up and BIOS change to “positive” and getting a few programs running and raising the temp, I just heard the fan for the first time around 50 deg C. So happy this was figured out!

This really was the only complaint I’ve had about the computer, so now I’m totally happy.

Hi @DragonHogan

Thanks for your support for this product, we are recently working on a new BIOS that added the option for always on for the fan, but figured out there were bugs so took it down for more testing, as soon as we finished testing we will release this BIOS again :smiley:

Hi everyone,

Good to know this is an issue also for other users.
This makes me believe the FAN is not defective. So this is either a software (EC Controller) issue when applying the correct Voltages or PWM settings, or an actual hardware problem (power/voltage delivery issue?)

An always on option with fixed PWM (max?) is not usefull. We need to get a good implementation on the PWM based on temp.

Guys,
Does your fan shows up in the BIOS when not spinning?
I just got a unit from Euro Amazon and it never spins the CPU, even when ubuntu reports temp of 56 deg.
Setting positive does not change a thing
in BIOS FAN is marked as N/A but it is connected and I can rotate is freely by hand.


I’m on the latest bios, Is the board defective?

latest BIOS should have the option of Always ON?

Well Ill be.

I remember this some time back with endless run-around and no resolution to my fan.
for refrence : Service Support Not Great and that is being really nice! Terminal : extremely or hopelessly severe

I have just received one myself from Amazon UK, I too also have the FAN issue, however it seems its an EC/BIOS tuning issue as the clicking is related to the fan trying to spin up (AKA not having enough power to spin it up).

However it will then come on at full wack for 5 seconds before going back to click click click.

I have noticed on the site that there is an update for the EC and BIOS question is which way do we flash it, BIOS first then EC or EC first then BIOS. the instructions on the site isn’t clear at all.

Flash EC first. :smile:

1 Like

Oops I flashed bios first, does it matter currently using it right now without issues. Hope I haven damaged the system.

It doesn’s matter. :smile:

1 Like

Thank you for your quick response. I do have a suggestion though as I did notice that the fan would just go to 100% rather then in % segments.

In the bios I did have it set to normal and as soon as it hit 50c it went to 100% for a few seconds and then back to fully off.

Would it possible to solve that also the CPU temps do not show either.

Will do a fully NVRAM reset later and then reflash EC and BIOS again to see if that solves it.

Currently I have it set to disabled for now as I am only going to run 2 vm’s one being a Windows and the other a docker.

The CPU temp info showed in first release BIOS version, it’s not really the CPU temp, so… :smile:

Yes that’s the behavior I also have.

No fix for this yet ? Is this a HW issue?

Not the HW issue, the CPU donot have the tem pin for EC reading.