Odyssey j4125 V2 BIOS update bricked device


I have a Odyssey blue J4125 v2 for which I tried to update the BIOS firmware, following the seedstudio wiki

As I have learned in this thread, the update procedure described on the seedstudio wiki is not valid for the newer V2 model, but only for the older V1 devices…

Flashing the (V1) BIOS from that page onto a V2 device seems to result in a bricked BIOS, i.e. the device powers up but no HDMI-signal is provided, which renders the device unusable.

I have followed the wiki, have read many forum posts about this issue and tried every suggested solution (unplugging RTC-battery to reset BIOS, waiting multiple hours etc.) but the device remains dead.

As I have a programmer that supports the Windbond W25Q64JW BIOS chip from this device, I would like to kindly ask if someone could provide the initial BIOS binary file for the V2, so that I can flash the correct image onto the chip.

Thank you in advance!

We have replied to you here; You can check it.