Not booting after BIOS update on ODYSSEY X86J4105

Hi.

After receiving the ODYSSEY-X86J4105 SBC (without eMMC version) from a seller in South Korea, I had tried to update BIOS of it before installing Windows 10 IoT.

I could finished all procedures as written on “https://wiki.seeedstudio.com/ODYSSEY-X86J4105-Installing-OS/” and " 2. If you have the non-EMMC version of ODYSSEY-X86 , before updating the BIOS, Please make sure to disable eMMC in the BIOS Settings Before and After the updates.".

  • SBC version : ODYSSEY-X86J4105 without eMMC
  • Old BIOS version : ?
  • New BIOS version : SD-BS-CJ41G-M-101-K.zip
  • eMMC : disabled in the BIOS settings before updates

After updating the new BIOS firmware successfully, I pushed the power switch button to reboot the ODYSSEY-X86J4105 board. However it couldn’t boot up and there were no powers to all peripheral devices like a monitor, a keyboard and a mouse.

In any cases, the BIOS should operate correctly before and after BIOS update but it wasn’t.
Please let me know why this serious problem was happened and how it can be solved.

Thanks.

Hi, pls wait a few minutes after update the bios, the board will reboot several times. You also need to update the EC firmware. Can you tell me which board in your hands?

Hi Bruce.

Thank you so much for your quick reply.

The board version is “ODYSSEY - X86J4105800 Most expandable Win10 Mini PC (Linux and Arduino Core) with 8GB RAM : Unactivated version without eMMC”.

Do you mean that the board will be automatically rebooted by itself several times without pushing the power button by a user ? According to “https://wiki.seeedstudio.com/ODYSSEY-X86J4105-Installing-OS/”, the user needs to push the power button after BIOS upgrade.

“When the BIOS is upgraded, reboot the ODYSSEY - X86J4105(Switch on and off the power).
The first boot up from the BIOS upgrade is relatively long , please be patient to wait, and the installed OS will launch eventually. It will take around 3 ~ 5 minutes”.

I pushed the power button of the board after BIOS upgrade to power off and on again and had waited for over 5 minutes but it wasn’t booting up. Since this board version does not have an eMMC, I assembled Samsung 970 Evo Plus 1TB SSD into the board before BIOS upgrade and disabled eMMC in BIOS. Can it be affected to this problem ?

You can see this issue on https://www.youtube.com/watch?v=T9ZhUtoZOOI&t=9s.

Thanks.

Hello,

after i upgrade one of my odyssey x86, i have same issue. It’s not booting.

Hi, how about your board, can it boot up now? You can remove the power supply and battery for a few minutes then retry.

I pulled out the power supply jack from the board over 1 hour and connected it again and tested several times but it wasn’t boot up. The BIOS was not working and the peripheral devices could not alive.

Can you remove the onboard battery for more try?

When the problem was occurred, I contacted the seller and he suggested me to test it after removing the onboard battery and I had tested it.
However the board couldn’t booting up correctly.

I have that problem too… I have removed battery, power cord, tried to restart but noting for 30 minutes. I think victorhsko uploaded a video in YouTube showing his case.

My Odyssey has been operating well with Linux Mint for more than a month.

are all problems with Non EMMC version ?

I updated my EMMC version with latest BIOS and Firmware.
there was no problem.

I did as below.

  1. install BIOS with built in shell from wiki installation.

  2. just power off by pushing power button.

  3. pushed power button again to boot up -> nothing happened. -> waited 5mins.

  4. pushed the button again -> it worked. booted up -> reboot 1 time automatically.

  5. works ok.

that’s what I did.

It could be with the non eMMC version. The procedure just “brick” the Odysseys. Mine has been working perfectly running Linux Mint. I didn’t have eMMC but installed the OS on a 512 GB Sata.

I would recommend not to update BIOS until the matter is resolved!!

@amichinel Hi , sorry for inconvenience to you. You can send it back to us for analyze what happened.

Maybe, yes.

I did exactly all procedures as you did.
However the board couldn’t boot up at 4 steps.

@victorhsko We have updated the instructions. After shell updated the BIOS, shutdown the board and remove all power, plug again and power on the board then wait 5-10 minutes, during this step, just waitting, do not touch the power key or remove the power, the board will reboot automatic.

Thanks… Please give me the instructions and address to sent it back to you.

I want to purchase another one. Can I have a coupon to reduce the cost?

But I am not sure I should buy without eMMC again. Please advice on that too if possible.

Hi, I have left the board unplugged and without battery overnight. Plugged it back this morning. The power came on ( the blue light came on)… but nothing… for 30 minutes or more is not booting up at all.

I have others SBC (4 raspberry Pi running as NAS, PLEX server, VPN and Homeassistant) and never had issues when updating eeprom firmware.

I have seen in the forum that many users have problem with the BIOS update… The fans not working… not able to boot, issues with monitors… etc, etc.

I thinnk Seeed Studio is releasing updates without a proper test and quality control on the stability of what is being released.

This is my second odyssey… in the 1st one I was not able to connect the BT antenna and pins came bent… I returned it and bought a new one… It was working ok until I unfurtunately decided to update the BIOS following the published procedure. Now what I got is a Blue Box with a blue light… nothing else.

Really sad…

@jiachenglu Pls help to send back.

According your applications to chosen the board. The BIOS is the same one in all versions.

Hi @amichinel
Please contact techsupport@seeed.cc for help to send it back.

I have a non eMMC version. I have updated BIOS and Firmware and the box works OK-ish. I have noticed that occasionally it does not boot; and stays stuck on the boot screen at that point I can turn it off with the power button and then I have to remove the power cord before pressing the power button to turn it back on.

For those who have the non eMMC version please check if you have disabled eMCC after the BIOS update.