J1010, how to detect and mount SD card in the SD card slot

The J1010 has a SD card slot included (On the carrier board).

However. If I insert a SD card (in the only way it seems to fit) it is not detected.

If I put the same SD card into and USB card reader and plug that into a USB port, it is detected. So the card is working.

The (Jetson?) OS is preinstalled on eMMC of 16GB. This eMMC is available on /dev/mmcblk0
I would expect the external SD card to show up on /dev/mmcblk1 ??

How can I use a SD card in the SD card slot and mount it?

I have the same issue. I am desperate. Please someone provide help. I tried to configurate .dtb files but it seems that the boot does not proceed from the eMMC memory but maybe in the QSPI memory. I tried a lot of things from nvidia forum but I m coming here now. I have seen on SeeedStudio wiki stuff but it does not apply to nano. See the link if it can helps ? reComputer for Jetson Initiation | Seeed Studio Wiki
Best regards,

If you want to flash the OS onto your SD card, you can follow this Wiki first:

Then follow the following Wiki:

thanks for your reply, I am not interested by flashing the OS onto the SD card but just use the SD card as an extra storage for my applications.
My SD card is not even detected by the hardware.
I did not try the " J101 Enable SD Card | Seeed Studio Wiki" and I’ll try it now, then get back to you.

EDIT : I now tried your gudie but step 3 does not work :
sudo /opt/nvidia/jetson-io/config-by-hardware.py -l
Command not found.
My card is still not read.

I don’t want to flash the entire OS onto the SD card. I just want to mount it to /usr/local/lib

This Wiki will show you how to use sd card in J1010 and install the driver for sd card

We have received your feedback and we will get back to you as soon as possible after testing

1 Like

Is there any news on this issue?

It looks like a hardware bug or driver bug, or missing driver module. I did modproble some sd card modules. But that did not help. The modules a simply not loaded without any message.

I would expect the SD card to run out-of-the box. Is this indeed not working for everybody out-of-the box of is it just me (and the other person in this tread) that have this problem?

Hello, this command can be executed normally, you can check again to see if the command is consistent with the Wiki during the input process

Hello Seraphina,
thanks for your time.
The thing is I don’t have the directory “jetson-io” on my jetson card. I did follow the step of the wiki. Instead I ave in my nvidia directory : " “l4t-bootloader-config” “l4t-usb-device-mode” “vpi1”. (I don’t have the config-by-hardware.py file either).
Best regards,

Maybe you can refresh the system, recommend JetPack4.6.1

Alright will do a new flash then.
I will keep you updated. Hope it will be usefull.
Thanks for your time.

1 Like

Hello again,
So I m struggling with sdkmanager and the flashing operation. I have SDKManager1.8.0.10363. First I used Ubuntu22.04 but this OS was not supported by the Jetson Nano because on the “target operating system” step, nothing was available for this version. I tried to install Ubuntu 18.04 on 2 different computers, but as the computers were too new, they did not support this OS. So I managed to find a CentOS.7.9.1908 but once again I have the same first issue. So my questions are : what OS on my host computer should I get for my Jetson Nano? Is there, instead, a version of sdkmanager that can fix my issue ?
Best regards,

This is the Host Operating System supported by JetPack

Thanks for the matrix, I have seen it already but are there any other possible way ? I think I can’t get a Ubuntu 18.04 and therefore a 16.04 …

Since I don’t have Ubuntu, I am trying to add an USB stick to my system with this tutorial

I am a bit worries about this step : Step 6. Modify the boot configuration to complete the expansion.
In fact, I have the file /boot/extlinux/extlinux.conf but I don’t have this one /media/nvidia/boot/extlinux/extlinux.conf.
I don’t have the nvidia directory, I have my user directory and the USB directory in /media.
I guess the “nvidia” directory is your user directory but my user directory is empty… However I did everything right before and nothing weird happened.
Therefore I have modified the rootf path in the /boot/extlinux/extlinux.conf file, and I am going to modify the path in the /media/USB/boot/extlinux/extlinux.conf file…
In the way I understand the tutorial, you modify the file on your system twice but not on the USB stick, and in my case I modify the file in my lcoal system and in my USB stick aswell.
Can you enlighten me on this subject ? Is there anything wrong ? What should I modify and where ? I don’t want to fail this step because I don’t have the possibility to do the backup step (no ubuntu…)
Best regards,

Through your question, the highest version of Ubuntu supported by your jetpack version is version 20.04, burning under version 22.04 will cause errors, maybe you can try to reinstall a version 20.04 ubuntu

Hello Jostar,
When reporting to the matrix the latest Jetpack version supported by Jetson Nano’s is 4.x so Ubuntu 18.04.
But my worries are more about the file to edit…

Hi,nano_o!Do you mean that you are more worried about formatting all files and programs when reburning the system? In the problem you described earlier, you mentioned that some files were missing due to a burn failure and suggested that the system need to be re-burned.I am deeply sorry and sad for the files cannot be backed up…

I read all the documents. But none of the document have answers to my questions in this topic. I am confused.

It seems to me every recomputer J1010 is missing the required driver. Not just my J1010. So basically it is a bug in the pre installed system because it is not working out of the box. Am I correct?

As far as my knowledge op linux goes, this should easily be fixed. Mobprobe the module should work, unless the kernel is not prepered for the module. In that case a new kernel-image should solve the problem. Normally you would be able to apt-get a new kernel image from respositories.Just apt-get install kernelpackage

I already did apt-get update && apt-get upgrade && apt-get autoremove

I do not understand the steps in the documentation. I do not understand what the commands are doing and and how they in any way are related to each other and to the issue that the operating system is not detecting the inserted micro SD card.

Can someone please explain a more high level overview of the cause of the problem and the solution?

Kind regards and many thanks in advance.