DSO nano new bootloader firmware

also it has a 500khz bandwidth, not the 1mhz that is claimed.

Fixed! Awesome!!

Thanks alf for the modified firmware files :smiley: It’s now better than the original firmware.

the sine wave is no wave at all, the peaks and low points are points instead of round…any ideas that would help me to round the peaks out. all that happens while i’m adjusting my amp gain is the entire sine rises instead of increasing in freq. incase this doesn’t work out, how can i get back to the original firmware? i have a minidso from edesign. thanks

:sunglasses: With the assistance of Dean of Wolverhampton (guiding me through some of my “firmware knowledge blind spots” by telephone), my thanks to Alf for the very useful update to DSO201. I’ve a lot to learn!! Thanks to both of you guys.

Help!! I recently bought a DSO nano from an ebay source (UK stock). Serial DECCACC4; Licence 035BACD2; Firmware V3.26D. Seems to be the genuine article.

I failed to download the recommended bootloader and firmware upgrade because the website referenced was in Chinese, in which I have zero capability. Even using Google translate it was impossible to navigate. However, having read such good things about BenF’s firmware, I decided to go for that, and after a long trawl round websites, I ended up here following everyone’s apparent successes.

OK, so I booted up the DSO with the ‘-’ button held down, copied one hex file to the virtual DSO drive, waited for the latter to vanish and reappear with the extension revised, then copied the other one. Waited a good couple of minutes, ejected the virtual DSO, and disconnected. Switched on the DSO…just got a blank flickering whitish screen, which stopped flickering if I pressed the (top) pause button but stayed blank. Seemed to be bggr*d.

Tried the whole procedure again. At least the DSO’s ‘awaiting upgrade’ screen was intact, but the second attempt was no more successful. I seem to have completely trashed the thing, and would be glad to get back to any firmware, although preferably the BenF. I have no idea where else to find the manufacturer’s firmware.

Anyone got any ideas, please?

So far it looks like the 3.26d bootloader is not working with benf but here is the stock firmware it is only one file
201V4_21.zip (37.7 KB)

Thanks so much!!! You saved my bacon. The gadget is back in working order.

Pity about benf - if anyone manages to solve that please let us know.

I second that!

After hours of unsuccessful attempts to flash the BenF firmware last night I quickly came to realise my new Amazon purchase is running the 3.26d boot loader. :frowning:

One thing I have noticed is the stock firmware for this unit is a single HEX file and not two separate LIB and APP HEX files as is the case with all the available versions of BenF’s firmware.

I did try copying both HEX files into one file and applying that but it didn’t make any difference.

Maybe the firmware just needs to be recompiled into a single file like the stock firmware is?

I have the same problem whit 3.26d there is no way to use the actual benf firmware.
Anyone has ideas on how to solve

Another vote for this, I have the same problem with firmware 3.26D,
The unit was bought from Amazon in the UK.

Would really like a way to install the BenF software, the unit doesn’t really do what I want it to in its current state.

[size=150]Hi There I too have exactly the same problem, I tried the dfuse and benf routine, useless…I tried the 2 hex files, copies perfectly ok, everything ok went from hex to rdy whatever, checked on the computer on e:/ programs on there ok, disconnect usb lead and put it back, programs still there, turn it of and on again, blank white screen, looked on computer again drive empty, it wont keep the hex files/rdy files whatever you do, wonder if there is anyway to put the original program back on, at least that worked, if anyone ever finds out please let me know, before I throw it away, done everything I can think of, might want to watch u tube clips on the nano, plenty of them,best wishes…Fred Nr London,[/size]

Yes, I had the flickering white screen as well, you can put the original (4.21) software back, it’s here …


(If that link doesn’t work, look at the post in this thread dated Thu Jul 18, 2013 2:23 am)

thanks the 4.21 works fine to solve the flickering problem :slight_smile:

We can only hope that Benf will come up with a solution for the 3.26D bootloader

Yeah, the units shipping with 4.21 can’t use any of the custom firmwares because these dsos now use a different lcd driver. That’s why we get the white screen of death. Apparently the original lcds are out of production.

It doesn’t look like this new firmware with the updated lcd drivers are open source either, complicating the matter of porting the drivers to benf. Still, I’m keeping my fingers crossed that someone smart can figure it out.

These units with 4.21 and another LCD controller, did you buy them from Seeedstudio? The info from Seeedstudio in the wiki says that the Nano v3 uses the same hardware and firmware as the v2, and that open-source is one of the features.

No, mine came from sainsmart via amazon. I figured a dso201 would be a dso201. :frowning:

No, if you buy a clone from a random dealer you don’t know what you get… The products are not the same and the vendors are not the same either. Seeedstudio stand behind their product and are supportive of open-source and alternative firmwares. And they host this forum for their customers… hint hint… When choosing a vendor to buy from you “vote” with your money.

Thanks for the ethics lesson. Words can not express the shame that fills my heart. :unamused:

Someone might as well lock this thread since only non-seeedstudio DSO’s are involved.