DSO nano new bootloader firmware

Hi all,

just bought a new DSO201 V1. Trying to upgrade FW i recognized that my DSO has a different Bootloader FW so i can´t update by using the DfuSe Software and the .dfu files. First of all the device is not recognized as “STM Device in DFU Mode” during driver installation. If i switch on the device pressing the - Button. Instead of this there is an entry named “Vertual DFU Disk USB Device” in the Win XP Devicemanager (really “Vertual”, not “Virtual”) and a virtual diskdrive named DFUV3_11_A appears in explorer.

The bootloader Screen on the DSO shows the e-Design Grafic but the Rest is completely different from what i´ve seen on different webpage screenshots.
Screen contains is a Serial and Licence- Number, followed by " Device Firmware Upgrade V3.20A" and “Please copy Hex or Bin file to the DFU virtual USB disk”

Obviously this is a new bootloader similar to the bootloader of the DSO203. So i tried to change the BenF Firmware v3.64 from .dfu to .hex by using the ST DFU File Manager and copied file by file to the virtual disk drive. What happened next was exactly what is described in the Firmware update manual of DSO203 Shortly the virtual disk disappears and it appears again showing the copied file with the ending .rdy instead of .hex

But this was it. The next time i turn on the DSO in Bootloader mode the Firmware on the DSO is just the old one and the .rdy file is gone.
By the way: Installed Lib version is 2.26 and App version is 2.6.

Is there anyone who had the same problem and solved it? I searched for a long time but until now i found no solution.
Hopefully anyone can help me. If helpful i can take some more screenshots of device.

Sorry for my bad english!

I have the same problem. Any help will be greatly appreciated.

Where did you buy these? I can’t believe eDesign or Seeed would have done this change in a product that has been sold for such a long time! Maybe these are experimental units shipped by accident?

Hello tormod!

I bought it in ebay shop. I think it´s a Chinese trader but shipping was from a storage in Germany.

This is even newer than DSO203’s. The 203 uses bootloader version 3.10… IMHO it’s an experimental version.

Is there any way to downgrade the bootloader to an older version (for example 2.0)?

Same model and problem here. Hope someone can come up with a fix for this.

I have just get my DSO nano from eBay and I have same problem too, any solutions?

Who is selling these devices? eBay is not one seller, you know…

ebay.pl/itm/270904020186?ssP … 2924wt_905

Interesting. In the sales description it says it ships with Paul’s Firmware v1.5. Well, I guess this is the kind of surprises you can get when not ordering through Seeed or other official dealers… Ask the dealer about what to do.

In theory you can reprogram the Seeed boot loader if there is / you make a program for it that you can install using the existing boot loader, or by opening the case and connect to the serial port (warning: these are not RS232 voltage levels).

Mine came from here. ebay.co.uk/itm/170665407367
Just have to stick to the original software then, oh well.

The interesting thing is that there are obviously chinese copies of chinese products and even with the same name.
Mine is from ebay.de/itm/150733890990?ssP … 1497.l2649

Supplier seems to be minidso.com and they sell a dso201 and a dso203.

Manufacturer: itfans.taobao.com ?

The minidso forum administrators warn about copies and have posted a guide on how to identify them: minidso.com/forum/viewtopic.php?f=5&t=1047

Hello Tormod!

Although my Chinese is not the best my DSO seems to be an original minidso but the discussion about original seeed or copy and so on is not very helpful to solve the posted problem.

Hi, have just received my DSO201 and am experiencing EXACTLY the same problem as mcguiver. My DSO203 upgrades easily but this 201 just reverts to its e-Design start up screen Lib 2.26 App 2.60 In bootloader it shows “device firmware upgrade V3.20A please copy Hex or Bin file to the DFU virtual disk”
I bought off e-bay in good faith and in fairness the service was excellent and scope works ok, and looks genuine but I would have really liked benf’s 3.64 running.
Have tried using the dfu demo but it doesn’t even see the 201
Like the rest I would appreciate any advice from the forum, thanks in hope :smiley:

It should not be a difficult task to open the case and establish serial communication. In this case is there a software for flashing the standard bootloader through serial port?

There are few posts by andrey that talks about bootloader flashing, but for [size=150]Nano V2[/size]. He actually flashed a blank chip. There is a v2 bootloader .bin attached in last post, pg 2. He is even open to questions.


A program for flashing via serial code.google.com/p/stm32flash/

But before anyone goes down that route, what does your vendor respond when you ask about this issue?! You paid for a seemingly broken product, it is not like you should have to open the case and reflash it yourself. Or maybe it just needs a special hex file?

Following a brief message to my supplier i received this reply

All of the *.hex format firmware are compatible .You can change others *.DFU firmware to hex format.
thank you!

  • malsdewd

Not very helpful! I have now sent more detailed information about the problem asking for advice and so far heard nothing back, will see how things develop.