DSO nano new bootloader firmware

I have the same problem whit 3.26d there is no way to use the actual benf firmware.
Anyone has ideas on how to solve
Thanks
Flavio

Another vote for this, I have the same problem with firmware 3.26D,
The unit was bought from Amazon in the UK.

Would really like a way to install the BenF software, the unit doesn’t really do what I want it to in its current state.

[size=150]Hi There I too have exactly the same problem, I tried the dfuse and benf routine, useless…I tried the 2 hex files, copies perfectly ok, everything ok went from hex to rdy whatever, checked on the computer on e:/ programs on there ok, disconnect usb lead and put it back, programs still there, turn it of and on again, blank white screen, looked on computer again drive empty, it wont keep the hex files/rdy files whatever you do, wonder if there is anyway to put the original program back on, at least that worked, if anyone ever finds out please let me know, before I throw it away, done everything I can think of, might want to watch u tube clips on the nano, plenty of them,best wishes…Fred Nr London,[/size]

Yes, I had the flickering white screen as well, you can put the original (4.21) software back, it’s here …

http://www.seeedstudio.com/forum/download/file.php?id=1512

(If that link doesn’t work, look at the post in this thread dated Thu Jul 18, 2013 2:23 am)

thanks the 4.21 works fine to solve the flickering problem :slight_smile:

We can only hope that Benf will come up with a solution for the 3.26D bootloader

Yeah, the units shipping with 4.21 can’t use any of the custom firmwares because these dsos now use a different lcd driver. That’s why we get the white screen of death. Apparently the original lcds are out of production.

It doesn’t look like this new firmware with the updated lcd drivers are open source either, complicating the matter of porting the drivers to benf. Still, I’m keeping my fingers crossed that someone smart can figure it out.

These units with 4.21 and another LCD controller, did you buy them from Seeedstudio? The info from Seeedstudio in the wiki says that the Nano v3 uses the same hardware and firmware as the v2, and that open-source is one of the features.

No, mine came from sainsmart via amazon. I figured a dso201 would be a dso201. :frowning:

No, if you buy a clone from a random dealer you don’t know what you get… The products are not the same and the vendors are not the same either. Seeedstudio stand behind their product and are supportive of open-source and alternative firmwares. And they host this forum for their customers… hint hint… When choosing a vendor to buy from you “vote” with your money.

Thanks for the ethics lesson. Words can not express the shame that fills my heart. :unamused:

Someone might as well lock this thread since only non-seeedstudio DSO’s are involved.

Well, I used my money to"Vote" for Amazon UK - hardly some cowboy outfit!

if he confess his sins before thee and me, and repenteth in the sincerity of his heart, him shall ye forgive

Note that Seeedstudio generously offers an “Others” forum section for “Externally-sourced products, anything you want to say.” So feel free to post there about these scopes. I wouldn’t mind a few posts here either, but it is getting really confusing with everybody filling this forum with their firmware issues on various devices, often without being able to explain what device they really have.

dso.218, you bought /through/ Amazon, not from Amazon, and you chose some dealer there. And it would anyway not help if Amazon is big and famous, if they don’t care about their customers.

All that said, this guy seems to insinuate that Seeedstore have messed up as well: viewtopic.php?f=3&t=4671

So I wrote to BenF through PM here on forum and I a send message to seller of Chinese DSO clone if they could send me source code for their firmware. If only we could get latest BenF source code and working “new LCD model” firmware source code it hopefully could get married.

New hardware is permanent/persistent issue and it won’t go away until we find a way around it. Help me out here if you can please.

Hello everybody BTW :wink:

[EDIT]
I found a hint on Chinese forum:
Previous LCD driver: 7781
Current LCD driver: 9341

www datasheetdir com / ST7781+download
www wdflcd com / xz / ILI9341_AN_V0.6_20110311.pdf

This (attached) is the source code of the latest version (4.22) that supports the new LCD driver. Isn’t that what tormod and palindrome ask for?
ds201v422 iar code.7z (2.01 MB)

Inshame, please see viewtopic.php?f=22&t=4823

I have a DSO201 made by minidso that I bricked by trying to upload their own firmware to it :imp:
In my quest to return it to a functional state, I downloaded the the zip file (BenF364_LIB353) and extracted the two files (V353_LIB.HEX and V364_APP.HEX). I connected my unit via the USB cable and powered it on in DFU mode. An icon titled “DFU V3_29_D” appeared under My Computer. I copied the V353_LIB.HEX file to the root folder of the device. Then I copied the V364_APP.HEX file to the root folder of the device. It disconnected and remounted and after that the two files showed as V353_LIB.RDY and V364_APP.RDY. I powered the device off, disconnected the cable, and powered it on again and now all I have is a flickering greyish screen. If anyone can tell me what I did wrong, I would be very appreciative as right now my DSO201 isn’t even a very good paper weight.

-Thanks

Hi the solution is explained here (flick screen):
viewtopic.php?f=22&t=4823

In agreement with that, the faq was also updated (How to upgrade the firmware):
viewtopic.php?f=22&t=4227

Hi there!

Any solution for this satrnge DSO201?

My shows:
Serial E3DBAFBB License87240531
V3.29D

Have the same white flickering screen iusse

I have developed one App for Android to read the files from BenF firmware an see the waves on your tablet screen, even make measures, very basic but it works!

I think I hit the same problem… copied the BenF .hex files to my 201, and it bricked to a white/grey screen… It also produced a .err file when it remounted… (pretty sure it was BenF 4.6.2 -App that bricked it.) Obtained the rar file from the link someone else provided. Hope it fixes things, Otherwise, I’m sunk… (and this makes #3 I’ve owned… the other two were lost when house was demolished… Don’t ask… L-O-N-G Story!)