A603 Carrier Board Issues (Flashing and USB)


I have two A603 carriers and both have the same issues. I cannot flash an Orin Nano 8GB on these carriers, the micro USB cables (I have tried many) are good - by this I mean they work for every other data task I need them for, is there a specific spec I should be looking for?

I am flashing to the NVME SSD using the steps on the wiki, A603 Carrier Board | Seeed Studio Wiki.

Note the flash always times out at:

Waiting for target to boot-up…
Cleaning up…

Now, if I flash Seeed’s custom BSP on the Nvidia Dev kit with the exact same module and SSD, it works, works as in flashes successfully.

However, when I put the module into the A603 (which should be fine as it was flashed using the scripts and BSP detailed on the wiki) and boot it up, it logs in and displays correctly but the USB A ports do not work at all. Which means I cannot control them.

To confirm, when trying to flash with the A603 in force recovery mode I do get “Bus 001 Device 019: ID 0955:7523 NVIDIA Corp. APX” returned with lsusb command.

So the micro USB connection works to a certain point, but it is odd that this fails eventually and the USB A ports also do not work.

I can provide order number if you need to check problems with a certain batch etc.

I have tested with both JetPack versions 5.1.1 and 5.1.2.

We have purchased two A603s and SSDs to go with them, which cannot be used on the dev kit due to them being 2242s and not 2280s, so we have spent a significant amount of time and money on this and would greatly appreciate any help that could be provided.

@Seeed_Seraphina any thoughts?

Many thanks,


I am struggling with the exact same issue today.

Hi @egradman @inov8s

There is indeed an issue with the current mirror provided by wiki. To address this situation, we have already produced a new version of the JP5.1.2 BSP. Under this new BSP version, we can use usbA normally. You can try using this latest BSP version.


Since this BSP is also a recent release aimed at resolving this problem, we will make sure to upload it to the wiki as soon as possible for everyone to download.

Thanks Seraphina appreciate the response and info.

Will try this and mark as solution if it resolves the USB A issue, any thoughts on flashing over micro USB not working? Do you have info on flashing over ethernet instead? Is there a default IP address?

Also, is there a JetPack 6.0 release with this fix scheduled for the A603? If so could you provide a rough estimate on timeline?

1 Like

Can you please confirm that your cable is a data cable? Because some cables can only be used as power cables and not for data transfer. And you need to make sure that the device has entered the forced recovery mode.

We have now made the BSP for A603 JP6 and started to enter the testing phase. We are aiming to be able to finish and release it in early June. Stay tuned!

Yes on both counts, regardless I’ve tested the new BSP version and can confirm it works. Thanks for the swift responses!

1 Like

After flash 5.1.2, my system does not have wifi icon in the settings (so I cannot connect to wifi). Is this also in your case? I find it weird that it does not have option of wifi connection

I’m only using ethernet currently so did not notice, but just checked and yes this is the same for me. No options show up in settings for it either, maybe needs enabled or something.

1 Like

Thank you for your reply.
@Seeed_Seraphina Any thought about enabling the wifi connection? Thank you.

Hi @inov8s @hongyuz
Have you added a network card to the M.2 Key E card slot? As far as I know, the A603 does not come with a pre-installed network card.

Thank you for the answer. I am also aware of that and will buy an Intel 8265.
Just a follow-up question, after slotting the wifi card into the A603 carrier board, will the Wi-Fi option be enabled immediately? Or do I need further setup like installing a wifi driver?

Hello everyone,
We have now updated the driver package and flashing tutorial for JetPack 6 on the wiki. Thank you all for your patience during this time!

Thanks for your replies and keeping us updated, appreciate it!

1 Like

@Seeed_Seraphina I have just flashed JP6 and the USB A ports are not working again. Is this a known issue again?

I can ssh into the board, dmesg output below if it’s useful.

sudo dmesg | grep -i USB
[ 0.097660] usbcore: registered new interface driver usbfs
[ 0.097686] usbcore: registered new interface driver hub
[ 0.097703] usbcore: registered new device driver usb
[ 0.227343] usbcore: registered new interface driver asix
[ 0.227363] usbcore: registered new interface driver ax88179_178a
[ 0.227381] usbcore: registered new interface driver cdc_ether
[ 0.227404] usbcore: registered new interface driver net1080
[ 0.227420] usbcore: registered new interface driver cdc_subset
[ 0.227437] usbcore: registered new interface driver zaurus
[ 0.227462] usbcore: registered new interface driver cdc_ncm
[ 0.227484] usbcore: registered new interface driver qmi_wwan
[ 0.227502] usbcore: registered new interface driver cdc_mbim
[ 0.229275] ehci_hcd: USB 2.0 ‘Enhanced’ Host Controller (EHCI) Driver
[ 0.229560] ohci_hcd: USB 1.1 ‘Open’ Host Controller (OHCI) Driver
[ 0.230147] usbcore: registered new interface driver cdc_wdm
[ 0.230181] usbcore: registered new interface driver usb-storage
[ 0.230275] usbcore: registered new interface driver option
[ 0.230291] usbserial: USB Serial support registered for GSM modem (1-port)
[ 1.568869] usbcore: registered new interface driver usbhid
[ 1.568875] usbhid: USB HID core driver
[ 1.635266] usbcore: registered new interface driver snd-usb-audio
[ 1.766452] tegra-xusb 3610000.usb: Adding to iommu group 2
[ 1.782063] tegra-xusb 3610000.usb: Firmware timestamp: 2023-02-10 03:48:10 UTC
[ 1.782073] tegra-xusb 3610000.usb: xHCI Host Controller
[ 1.782088] tegra-xusb 3610000.usb: new USB bus registered, assigned bus number 1
[ 1.782836] tegra-xusb 3610000.usb: hcc params 0x0180ff05 hci version 0x120 quirks 0x0000000000010810
[ 1.782861] tegra-xusb 3610000.usb: irq 124, io mem 0x03610000
[ 1.782994] tegra-xusb 3610000.usb: xHCI Host Controller
[ 1.782998] tegra-xusb 3610000.usb: new USB bus registered, assigned bus number 2
[ 1.783002] tegra-xusb 3610000.usb: Host supports USB 3.1 Enhanced SuperSpeed
[ 1.783278] hub 1-0:1.0: USB hub found
[ 1.783594] hub 2-0:1.0: USB hub found
[ 2.121431] usb 1-3: new high-speed USB device number 2 using tegra-xusb
[ 2.274417] hub 1-3:1.0: USB hub found
[ 6.263663] tegra-xudc 3550000.usb: Adding to iommu group 5
[ 10.498098] usb0: HOST MAC ae:41:1a:0e:f4:8c
[ 10.498108] usb0: MAC ae:41:1a:0e:f4:8d
[ 10.498567] usb1: HOST MAC ae:41:1a:0e:f4:8e
[ 10.498571] usb1: MAC ae:41:1a:0e:f4:8f
[ 10.502224] tegra-xudc 3550000.usb: EP 0 (type: ctrl, dir: out) enabled
[ 10.522386] l4tbr0: port 1(usb0) entered blocking state
[ 10.522407] l4tbr0: port 1(usb0) entered disabled state
[ 10.548994] device usb0 entered promiscuous mode
[ 10.620056] l4tbr0: port 2(usb1) entered blocking state
[ 10.620075] l4tbr0: port 2(usb1) entered disabled state
[ 10.621984] device usb1 entered promiscuous mode
[ 11.059256] fusb301 1-0025: failed to read device id, err : 0xffffff87
[ 11.059265] fusb301 1-0025: fusb301 not support
[ 11.059271] fusb301: probe of 1-0025 failed with error -22

May I ask if you have confirmed that you have successfully replaced the driver? We have tested it and found that the USB is working fine.

I replace the JP5.1.2 BSP I provided on my A603 and install the intel 8265 network card. As soon as I turn on the system, not only was there a wifi logo, but also able to connect to wifi easily without having to install any additional driver for the intel 8265
It’s running fine

1 Like

Oh, no I haven’t. Are there instructions on how to do this? I must have missed it somewhere. Is it possible to do on a running system or do you have to do it pre-flashing?

@Seeed_Seraphina any advice on this?

Have you confirmed that you have replaced the BSP? We can make sure that the connected usbA is working properly

Hi Seraphina,

If you mean this step:


To double-check if there was any corruption etc I re-did the entire procedure via the wiki, again, and the same result - no USB A functionality.

This is for a Orin Nano JetPack 6.0, L4T 36.3 using the link in the wiki (https://nv-jetson-images.oss-us-west-1.aliyuncs.com/A603/A603-JP6.0.zip?OSSAccessKeyId=LTAI5tKm7UD2hmuFW85cz42T&Expires=4869959719&Signature=1SFOkIWHlDIaZzCAR2af9%2F4DFj0%3D).

You can see the downloads were from today:

I will attach the initrd log as well.

I appreciate that you are saying it works on your end, but I have followed the wiki twice now and it does not work for me. Can this please be investigated?



logs.zip (51.9 KB)