A603 Carrier Board Issues (Flashing and USB)

The tutorial you are looking at is not for the JP6 version. We have confirmed that if you do not use sudo when replacing the driver, the replacement will not be successful. So we have deliberately used sudo for all the commands in the wiki for A603 JP6.0.

Hi Seraphina,

I have been using the correct tutorial just pasted that image as it’s more or less the same step each time. Apologies for the confusion.

From the logs I provided, you can see I did use sudo and typed ‘A’ to replace the files:

steven@acer-linux:~/Downloads/NVIDIA/JetsonOrinNano$ sudo unzip A603-JP6.0.zip
Archive: A603-JP6.0.zip
replace Linux_for_Tegra/bootloader/generic/BCT/tegra234-mb1-bct-pinmux-p3767-dp-a03.dtsi? [y]es, [n]o, [A]ll, [N]one, [r]ename: A
inflating: Linux_for_Tegra/bootloader/generic/BCT/tegra234-mb1-bct-pinmux-p3767-dp-a03.dtsi
inflating: Linux_for_Tegra/bootloader/tegra234-mb1-bct-gpio-p3767-dp-a03.dtsi
inflating: Linux_for_Tegra/kernel/dtb/tegra234-p3768-0000+p3767-0003-nv.dtb
inflating: Linux_for_Tegra/kernel/dtb/tegra234-p3768-0000+p3767-0004-nv.dtb
inflating: Linux_for_Tegra/kernel/dtb/tegra234-p3768-0000+p3767-0000-nv.dtb
inflating: Linux_for_Tegra/kernel/dtb/tegra234-p3768-0000+p3767-0001-nv.dtb
inflating: Linux_for_Tegra/kernel/dtb/tegra234-p3768-0000+p3767-0000-dynamic.dtbo
inflating: Linux_for_Tegra/kernel/Image
creating: Linux_for_Tegra/rootfs/usr/lib/modules/5.15.136-tegra/kernel/drivers/net/wireless/intel/
creating: Linux_for_Tegra/rootfs/usr/lib/modules/5.15.136-tegra/kernel/drivers/net/wireless/intel/iwlwifi/
inflating: Linux_for_Tegra/rootfs/usr/lib/modules/5.15.136-tegra/kernel/drivers/net/wireless/intel/iwlwifi/iwlwifi.ko
creating: Linux_for_Tegra/rootfs/usr/lib/modules/5.15.136-tegra/kernel/drivers/net/wireless/intel/iwlwifi/mvm/
inflating: Linux_for_Tegra/rootfs/usr/lib/modules/5.15.136-tegra/kernel/drivers/net/wireless/intel/iwlwifi/mvm/iwlmvm.ko
creating: Linux_for_Tegra/rootfs/usr/lib/modules/5.15.136-tegra/kernel/drivers/net/wireless/intel/iwlwifi/dvm/
inflating: Linux_for_Tegra/rootfs/usr/lib/modules/5.15.136-tegra/kernel/drivers/net/wireless/intel/iwlwifi/dvm/iwldvm.ko

So from what I’m reading, I’m following the instructions exactly but the USBs are not working. The BSP on the previous wiki were incorrect, could this not be the case again? There’s nothing else I can do from my side.

Today we try again to flash JP6 using the exact steps as documented in the wiki . After flashing, we can still use USB normally. Please refer to the GIF I sent. I have a keyboard and mouse connected and both work fine

I suggest you use the following method to check if your driver program has been successfully replaced. Compare the files before and after the replacement to see if they are different (refer to the filenames that appeared during our replacement process).

1 Move the downloaded peripheral drivers from before into the same folder with NVIDIA drivers. Now you will see three compressed files in the same folder. Open a terminal in this folder

2 Run this command to check the filenames in the path before the replacement. See if they match the ones shown in the picture below.

$ sha1sum ./Linux_for_Tegra/kernel/Image

3 Following the step3 and step4 in wiki. Use sudo to replace the driver

4 Run the command again to check if the current filenames are different from the filenames before the replacement. If they are different, it indicates that the replacement was successful.

$ sha1sum ./Linux_for_Tegra/kernel/Image

Thanks Seraphina, really appreciate the effort in trying to resolve this.

So I did exactly what you described above, got the same sha outputs as yourself - i.e. initially before replacement:

sha1sum ./Linux_for_Tegra/kernel/Image
ff68c1a061ed75cee73afc4fd98f89efa01e287f ./Linux_for_Tegra/kernel/Image

and then after sudo unzip A603-JP6.0.zip:

sha1sum ./Linux_for_Tegra/kernel/Image
601d40816e99976ed84c55adb7e11b4d685c4909 ./Linux_for_Tegra/kernel/Image

Then created the default user, flashed board etc.

Booted device and still no USB. Tried my other A603 board as I have two, same result.

Is there any hardware differences in the recent PCB builds etc? I’m really struggling here, I need this to work and don’t have a lot of time to keep dedicating to it.

I know from your end it must be really frustrating for you because it works, but it doesn’t for me.

I can ssh into the board, enable VNC etc. HDMI works.

Is there any way to install the USB driver live on a running jetson, that may be the last thing to try.

We are very sorry for any inconvenience!
Here’s the version info for my board. You can compare it.

Thanks for the image, I have the same version. Really strange.

I have contacted you via message and we can communicate in it

Hello –
Several months ago I was able to successfully flash my Orin NX on an A603 to JP 5.1.2 using the steps and files in the wiki.

This week I tried to follow the steps in the wiki (on the same computer, just a fresh download) and flashing fails. On the host side, it times out with “waiting for target to boot up” and the device side serial logs end with:

enable remote access
insmod /lib/modules/5.10.120-tegra/kernel/drivers/mtd/mtd.ko 
insmod /lib/modules/5.10.120-tegra/kernel/drivers/mtd/devices/qspi_mtd.ko 
[    8.458762] qspi_mtd spi6.0: MX25U51279G (65536 Kbytes)
[    8.461874] qspi_mtd spi6.0: mtd .name = spi6.0, .size = 0x4000000 (64MiB) .erasesize = 0x00010000 (64KiB) .numeraseregions = 0
[    8.476432] 1 fixed-partitions partitions found on MTD device spi6.0
[    8.479900] Creating 1 MTD partitions on "spi6.0":
[    8.484876] 0x000000000000-0x000004000000 : "Whole_flash0"
insmod /lib/modules/5.10.120-tegra/kernel/drivers/spi/spi-tegra210-qspi.ko 
insmod /lib/modules/5.10.120-tegra/kernel/drivers/hwmon/pwm-fan.ko 
[    8.513903] using random self ethernet address
[    8.514029] using random host ethernet address
[    8.516718] Mass Storage Function, version: 2009/09/11
[    8.517339] LUN: removable file: (no medium)
[    8.522899] LUN: removable file: (no medium)
[    8.527189] LUN: removable file: (no medium)
[    8.531671] LUN: removable file: (no medium)
Add /dev/nvme0n1
[    8.538683] rndis0: HOST MAC ba:61:4d:39:d6:e1
[    8.541411] rndis0: MAC 52:49:86:57:7b:b1
[    8.545729] tegra-xudc 3550000.xudc: EP 0 (type: ctrl, dir: out) enabled
bash: cannot set terminal process group (-1): Inappropriate ioctl for device
bash: no job control in this shell
bash-5.0# [   10.550789] tegra-xusb 3610000.xhci: entering ELPG done

Can you help me figure out what is going on? For what its worth, I’m able to flash to jetpack 6 using the instructions in the wiki but I need jetpack 5.1.2 for my project.