How to work with respeaker in pulse mode?

info about ReSpeaker series products

Moderators: lily.li, violet, seth.welday

Post Reply
rodionov12
Pre-kindergarten
Pre-kindergarten
Posts: 5
Joined: Wed Oct 24, 2018 12:02 am

How to work with respeaker in pulse mode?

Post by rodionov12 » Mon Oct 29, 2018 9:07 pm

Hello! Please, describe how to use respeakerd in pulse mode?

I'm trying to code home assistant using another STT vendor (not Amazon). For interconnection with respeakerd I need to use pulseaudio output channel. How to do this?
I'm trying to look at Google Home Assistant example, but D-Bus doesn't working. My steps:
1. Enable D-Bus for all messages and paths

Code: Select all

cat /etc/dbus-1/system.d/io.respeaker.respeakerd.conf
<busconfig>
  <policy context="default">
    <!-- Allow everything to be sent -->
    <allow send_destination="*" eavesdrop="true"/>
    <!-- Allow everything to be received -->
    <allow eavesdrop="true"/>
    <!-- Allow anyone to own anything -->
    <allow own="*"/>
    <!-- XXX: Allow all users to connect -->
    <allow user="*"/>
  </policy>
</busconfig>

2. Listening d-bus for info:

Code: Select all

dbus-monitor --system
signal time=1540817661.428186 sender=:1.29 -> destination=(null destination) serial=3 path=/io/respeaker/respeakerd; interface=respeakerd.signal; member=respeakerd_ready
signal time=1540817800.946534 sender=:1.32 -> destination=(null destination) serial=5 path=/io/respeaker/respeakerd; interface=respeakerd.signal; member=ready
And there is nothing:

Code: Select all

get d-bus connection ...
connected to fifo file: /tmp/music.input
(91ms)INFO  -- pulseaudio context connecting...  [pulse_collector_node.cc:140]
(94ms)INFO  -- pulseaudio context connected to the server.  [pulse_collector_node.cc:164]
(94ms)INFO  -- The target source name: default  [pulse_collector_node.cc:167]
(95ms)INFO  -- The source's original info: name: alsa_input.platform-sound_0.seeed-8ch, rate: 48000, format: s16le, channels:8  [pulse_collector_node.cc:195]
(95ms)INFO  -- The source's negociated info: name: alsa_input.platform-sound_0.seeed-8ch, rate: 16000, format: s16le, channels:8, flat volume: 1  [pulse_collector_node.cc:213]
(378ms)INFO  -- Connected to PulseAudio server.  [pulse_collector_node.cc:255]
(378ms)INFO  -- PulseCollectorNode thread started.  [pulse_collector_node.cc:276]
(379ms)INFO  -- HybridNode is accepting deinterleaved data.  [hybrid_node.cc:176]
(412ms)INFO  -- HybridNode thread started.  [hybrid_node.cc:260]
(413ms)INFO  -- VepAecBeamformingNode thread started.  [vep_aec_bf_node.cc:234]
(444ms)INFO  -- VepDoaKwsNode enabled AGC.  [vep_doa_kws_node.cc:295]
(444ms)INFO  -- VepDoaKwsNode thread started.  [vep_doa_kws_node.cc:312]
respeakerd output: num channels: 1, rate: 16000
waiting for ready signal...
assuming cloud always ready for PulseAudio mode
going to send d-bus signal: respeakerd_ready
(20060ms)INFO  -- >>>> The decided trigger beam is 5(4.5), dir: 270`. <<<<  [vep_doa_kws_node.cc:572]
it detects hotword, but never calls event in d-bus. googlesamples-assistant-respeakerd doesn't show any information in console, even in debug logging level.

How can I find "respeakerd_output" in pulse sources? I'm using pactl list but there is nothing with such name

seeed techsupport team
Staff
Staff
Posts: 44
Joined: Mon Mar 19, 2018 11:40 am

Re: How to work with respeaker in pulse mode?

Post by seeed techsupport team » Wed Dec 05, 2018 6:23 pm

Hi there,

please refer to https://github.com/respeaker/respeakerd ... audio-mode for start respeakerd in PulseAudio mode. thanks.

Post Reply