Music Shield not playing

Ardiuno Compatible shields

Moderators: lily.li, violet

JLPaquin
Pre-kindergarten
Pre-kindergarten
Posts: 2
Joined: Fri Feb 17, 2012 11:26 am
Are you a staff member of seeedstudio?: no
Which products/projects are your favorite?: Music Shield

Music Shield not playing

Post by JLPaquin » Fri Feb 17, 2012 11:46 am

I have recently purchased some Music Shields and they are not working at all.

The Music Shields boards are versions 1.2 and 1.3

I have tried software version 1.14 with Arduino version 022 and version 1.2 with Arduino version 1.0

The both version of the software were installed and compiled according to the instructions in your Wiki according to each Arduino version

With the Arduino 022 version it was tried using Arduino UNO R2 and Arduino R3 boards

With the Arduino 1.0 version it was tried using Arduino UNO R2, Arduino R3 and Arduino Mega 2560 boards

SD cards of 2Gb and 128Mb were tried, both non HD types.

The SD cards were tested formatted using both FAT 16 and FAT32

Various MP3s were tried at various bitrates

The problem is the same with all tests. The green light of the Music Shield is lit but does not blink. No other light is working. All the buttons are unresponsive, and no music is playing.

Opening a serial monitor window does not display anything at all.

I would greatly appreciate some support to resolve that issue as I have multiple Music Shields that are totally useless right now as they are totally unresponsive and do not play music.

yuriq
Elementary-3
Elementary-3
Posts: 383
Joined: Wed Dec 07, 2011 5:33 pm

Re: Music Shield not playing

Post by yuriq » Fri Feb 17, 2012 5:36 pm

Hi there,

The rocker which is the middle one on the music shield you also pass down?Then not thing happen?
Do you upload perfect with the demo code?
The rocker turn right is next song and left is turn over again, but pass down is play music.

Best regards,

Yuri

JLPaquin
Pre-kindergarten
Pre-kindergarten
Posts: 2
Joined: Fri Feb 17, 2012 11:26 am
Are you a staff member of seeedstudio?: no
Which products/projects are your favorite?: Music Shield

Re: Music Shield not playing

Post by JLPaquin » Fri Feb 17, 2012 10:31 pm

Dear Yuri,

The code was compiled and installed as explained in the Wiki and it compiles and uploads with no error.

The rocker does not do anything. If I press it nothing happens. If I push it left or right nothing happens. In all case the green light stays steadily lit.

I have also just tested with a version 1.1 board as I found out I had one too. It is doing exactly the same thing.

Any help would be greatly appreciated. Do you have some mp3 files that are know to work properly as this is the only thing that I cannot isolate as I do not know what should work.

Luc

sabor
Pre-kindergarten
Pre-kindergarten
Posts: 3
Joined: Thu May 17, 2012 3:17 pm
Are you a staff member of seeedstudio?: no
Which products/projects are your favorite?: camera

Re: Music Shield not playing

Post by sabor » Thu May 17, 2012 3:30 pm

Hi JLPaquin,

I noticed that your last comment is exactly three months ago.
Does that means that you have solved the problem?
I am facing the identical problem right now.
Any idea how to solve it?

Thanks! :!:

Tobe
Pre-kindergarten
Pre-kindergarten
Posts: 34
Joined: Tue Jan 17, 2012 11:04 am
Are you a staff member of seeedstudio?: yes
Which products/projects are your favorite?: Seeeduino

Re: Music Shield not playing

Post by Tobe » Tue May 22, 2012 4:38 pm

Hi there:
I fllow the wiki,try the Demo 1,for the Demo 1,there has some notic,when you are download the Music v1.2.zip and uncompress it under the arduino-1.0 lib floder, then do not download the Demo 2 's lib,just say Music v1.2 and MusicShieldNewSDLib can not be in the same Lib floder.
After that,I open the example,and download it to my Arduino UNO R3,the first time,it do not work,just like yours,green light is light,not blink,red light is not light.And then,I turn of the power,and plug the USB Cable in again.It;s work,palying the nice music.
You can try it.

kyosho01
Pre-kindergarten
Pre-kindergarten
Posts: 1
Joined: Sun Jun 03, 2012 3:42 am
Are you a staff member of seeedstudio?: no
Which products/projects are your favorite?: arduino

Re: Music Shield not playing

Post by kyosho01 » Sun Jun 03, 2012 3:44 am

I am having the same exact problem. I installed everything exactly as in the wiki, and the green light just stays on and no music. Clearly there is a problem, is this many people have the same issue, and does SeeedStudio even respond to these issues!!? I am ready to just return the damn thing.

sabor
Pre-kindergarten
Pre-kindergarten
Posts: 3
Joined: Thu May 17, 2012 3:17 pm
Are you a staff member of seeedstudio?: no
Which products/projects are your favorite?: camera

Re: Music Shield not playing

Post by sabor » Tue Jun 05, 2012 11:57 am

Hi kyosho01,

I solved my problem with my friend's help.
Know what he did? He just changed to use a better/faster microSD card and everything is working perfectly now.
U might want to try it too.
Hope it helps you :D :D :D

Karl_Smithe
Pre-kindergarten
Pre-kindergarten
Posts: 1
Joined: Fri Jun 08, 2012 7:20 am
Are you a staff member of seeedstudio?: no
Which products/projects are your favorite?: music shield

Re: Music Shield not playing

Post by Karl_Smithe » Fri Jun 08, 2012 8:36 am

Greetings and salutations. This is my first post.

I just got a Seeedstudio Music Shield a couple of days ago. I have it plugged into an Arduino Uno and have been trying to compile the example programs.

I have gotten the following errors:

This error is from MusicPlayWithName:
C:\SW\Arduino-1.0.1\libraries\MusicShieldNewSDLib\player.cpp: In function 'int playFile()':
C:\SW\Arduino-1.0.1\libraries\MusicShieldNewSDLib\player.cpp:136: error: 'listoffset' was not declared in this scope
C:\SW\Arduino-1.0.1\libraries\MusicShieldNewSDLib\player.cpp:137: error: 'indexlist' was not declared in this scope
This error is from MusicPlayRandomly:
sketch_MusRanPlay.cpp: In function 'void loop()':
sketch_MusRanPlay:62: error: 'class Fat16' has no member named 'traverseDir'
This error is from MusicPlayAlll:
musicPlayAll.cpp: In function 'void loop()':
musicPlayAll:59: error: 'Play' was not declared in this scope
I have searched the content I downloaded and unziped and the term 'traverseDir' does not show up so it is no wonder that it is not found.

So can anyone help me get this running?

KS

todicus
Pre-kindergarten
Pre-kindergarten
Posts: 2
Joined: Wed Nov 07, 2012 7:14 am

Re: Music Shield not playing

Post by todicus » Wed Nov 07, 2012 7:23 am

I am also getting these errors for the Demo 2 sketch called "MusicPlayWithName.ino", using Arduino 1.01:

/Arduino/libraries/MusicShieldNewSDLib/player.cpp: In function 'int playFile()':
/Arduino/libraries/MusicShieldNewSDLib/player.cpp:136: error: 'listoffset' was not declared in this scope
/Arduino/libraries/MusicShieldNewSDLib/player.cpp:137: error: 'indexlist' was not declared in this scope

Looking at the code, it certainly does appear that these variables are never defined. Has anyone gotten Demo 2 sketches to work? The Demo 1 sketch "musicPlayAll.ino" works just fine on my hardware.

User avatar
Jacket Chen
Staff
Staff
Posts: 659
Joined: Thu Jun 21, 2012 4:25 pm
Are you a staff member of seeedstudio?: yes
Which products/projects are your favorite?: Seeeduino Shields
Location: China

Re: Music Shield not playing

Post by Jacket Chen » Wed Nov 07, 2012 11:53 am

todicus wrote:I am also getting these errors for the Demo 2 sketch called "MusicPlayWithName.ino", using Arduino 1.01:

/Arduino/libraries/MusicShieldNewSDLib/player.cpp: In function 'int playFile()':
/Arduino/libraries/MusicShieldNewSDLib/player.cpp:136: error: 'listoffset' was not declared in this scope
/Arduino/libraries/MusicShieldNewSDLib/player.cpp:137: error: 'indexlist' was not declared in this scope

Looking at the code, it certainly does appear that these variables are never defined. Has anyone gotten Demo 2 sketches to work? The Demo 1 sketch "musicPlayAll.ino" works just fine on my hardware.
Dear todicus
Here is something you might notice:the MusicShieldNewSDLib can't co-exist with MusicPlayer_v1_7 or other versions,so you would delete others within libraries.The same to Fat16.
Might those would be helpful to you.

Best Regards
Jacket
Love little, love long.

Post Reply