XIAO BLE Sense Grove - OLED Display 0.66" Not Working

HAs anyone been able to use the nRF Sense BLE with the Grove .66 OLED. I am trying to follow the instruction shown in the motion recognition tutorial but it is not working.
I have tried multiple different sample codes, to no avail.

Any help would be appreciated.

I have tried to connect a Lipo Battery and external power too.

Using I2C_SCANNER, can you find the address “0x3C” of the OLED?
nRF52_XIAO_mbed_I2C_scanner.zip (697 Bytes)

@msfujino yes. I used the I2C scan to confirm the port. The port is correct but it doesn’t seem to work.

Is the board library “Seeed nRF52 mbed-enabled Borads 2.9.0”?
Is the board selection “Seeed nRF52 mbed-enabled Borads / Seeed XIAO BLE Sense - nRF52840”?
Was the address of the OLED “0x3C”?
Does a simple sketch “blink” work?
Have you tried IMU sample sketches?
Have you tried the OLED sample sketches?

“Seeed nRF52 mbed-enabled Board version is 2.8.1
Board selected in Sense
Checked the address using i2c scanner. 0x3C confirmed
Tried blink and imu demo and passed
Tried OLD but failed. Tried with the Seeed Studios expansion board OLED too. Failed

Please show me the sample sketch that you have tried on your expansion board.