XIAO BLE SENSE cannot communicate with IMU sensor

Thanks for your response. I tried using “Seeed nRF52 mbed-enabled Boards 2.8.1” but get this error:

Error: 13 INTERNAL: Cannot install platform: installing platform Seeeduino:mbed@2.8.1: searching package root dir: no unique root dir in archive, found ‘/Users/a2530/Library/Arduino15/tmp/package-3768760097/.github’ and ‘/Users/a2530/Library/Arduino15/tmp/package-3768760097/bootloaders’

I was able to specifically install the “Seeed nRF52 mbed-enabled Boards” version 2.7.2, but I get the same error as Hardeep_Singh when I try to update it to 2.8.1 - it’s clear that something is broken in the Board JSON file provided by Seeed. I hope Seeed can see and fix this! @msfujino - the 2.8.1 version doesn’t install on the Arduino IDE (I use version 2.0.3, which is the current download).

I installed on IDE 1.8.19 and am using it with IDE 2.0.3.
For problems with IDE2.0, you can post in the following forum, which will confirm and solve your problem in a very short time.When using mbed2.8.1, please also refer to the following link.

Are you suggesting using IDE 1.8 to make BLE sensor work until Arduino fixes 2.0.3 issues?

If you install mbed2.8.1 using the board manager of IDE1.8.19, it will be installed in the following directory This can also be used from IDE2.0.3.


For your information

Hi everyone,
I am working with xiao ble in mbed version. I could not make the lsm6ds3 and mlx90614 work together(at same time). But it was possible for me to work the lsm6ds3 with max30100 and get the imu values and spo2. When i work with mlx90614, it is not printing any imu values or temperature and also it did not pop any error when i compile.

sounds like an address issue? if you ask me?
GL :slight_smile:

Hi PJ_Glasso,

Thank you for your quick reply. I will try to look into it


Sure, Post up your code, I can look . Be sure to use the code tags.
5A :grin:

Hello Dave,

I followed your exact steps to try to get the HighLevelExample sketch to communicate with the IMU however, I still get a device error and static values for the accelerometer and gyroscope. I’m using a Linux machine and have Arduino 1.8.19 installed. I have the same versions of the libraries installed that you have.

Thanks in advance for you help,

Would the following links be helpful?