Seeed nRF52 mbed-enabled boards 2.8.1 IMU return static values


I i’m trying to use the IMU the Seeed XIAO sense with the Seeed nRF52 mbed-enabled boards 2.8.1.

I am using the HighLevel exampel, however it only returns a static value for accelerometer, gyroscope and the thermometer.

Serial output:
Y1 = 0.7291
Z1 = 0.7291

X1 = 104.5800
Y1 = 104.5800
Z1 = 104.5800

Degrees C1 = inf
Degrees F1 = inf

There is no error during upload or setup.
Hope you can help recieving real readings.

Hmm, I just loaded it and I get good data from the jump… Check your setup the code does compile , download and work as-is. 100% Those are NOT good readings…

X1 = 0.0327
Y1 = -0.0171
Z1 = 1.0258

X1 = 0.0700
Y1 = -9.1000
Z1 = 0.4900

Degrees C1 = 29.1797
Degrees F1 = 84.5234

Degrees C1 = 32.2578
Degrees F1 = 90.0641

temp goes up when I finger it and X & Y & Z change when I flip it over.
X1 = 0.0600
Y1 = -0.0425
Z1 = -0.9638

X1 = -0.2100
Y1 = -3.2200
Z1 = -1.4000

Degrees C1 = 32.3242
Degrees F1 = 90.1836
(flipped & heated)

GL :slight_smile:

This happens when mistakenly selected “Seeed nRF52 Boards/Seeed XIAO nRF52840 Sense” (non-mbed) in boat selection.
“Seeed nRF52 mbed-enable Boards/Seeed XIAO BLE Sence - nRF52840” must be selected.

1 Like

Hi PJ_Glasso and msfujino

Thanks for the respond.

PJ_Glasso: I am using the highlevel example out of the box and get static values.

msfujino: I have checked and I am using the mbed boards and still get static values.

I have borrowed another Seeed nRF52840 sense board of my friend and with the same setup (High level example and mbed board setting) the imu returns perfect imu readings. Is it possible to hard reset the board? or any suggestion on why the imu is not working?

best regards

The fact that the other board work indicates that your board is most likely defective.

My own board is all new, i have never used it and bought it for 7 days ago.

You don’t have any suggestions on factory rest or software fixes?

Is your board “XIAO_nRF52” instead of “XIAO_nRF52_Sense”?
I ran the IMU sketch on “XIAO_nRF52” and got the same results as you posted.

Try running the attached I2C scanner sketch, can you find the IMU address “0x6A”? (809 Bytes)

Hi msfujino

Thanks again. I tried byt the scanner could not find the address.

I have ordered a new board for my project.