XIAO BLE (nrf52840) - bootloader problem - (after nordic sdk)

Hi, I tried a lot of seeks to be able to use the BLE on the xiao ble board. (Today I got a hint that i can use arduinoBLE.h just with the Seeed nRF52 mbed-enabled Boards” and not the other one.)

Since yesterday I tried to use the nordic sdk - today arduino can not upload anymore any code to the board with the following error:
(anyway even the board is not recognized on that port - I checked the port is OK)

Waiting for upload port…
No upload port found, using COM11 as fallback
“C:\Users\szabo\AppData\Local\Arduino15\packages\Seeeduino\hardware\nrf52\1.1.1/tools/adafruit-nrfutil/win32/adafruit-nrfutil.exe” --verbose dfu serial -pkg “C:\Users\szabo\AppData\Local\Temp\arduino\sketches\870118291F33E120FE405E64F9022154/bb_BLE.ino.zip” -p COM11 -b 115200 --singlebank
Upgrading target on COM11 with DFU package C:\Users\szabo\AppData\Local\Temp\arduino\sketches\870118291F33E120FE405E64F9022154\bb_BLE.ino.zip. Flow control is disabled, Single bank, Touch disabled
Opened serial port COM11
Starting DFU upgrade of type 4, SoftDevice size: 0, bootloader size: 0, application size: 116812
Sending DFU start packet
Timed out waiting for acknowledgement from device.

Failed to upgrade target. Error is: No data received on serial port. Not able to proceed.
Traceback (most recent call last):
File “main.py”, line 296, in serial
File “dfu\dfu.py”, line 235, in dfu_send_images
File “dfu\dfu.py”, line 199, in _dfu_send_image
File “dfu\dfu_transport_serial.py”, line 179, in send_start_dfu
File “dfu\dfu_transport_serial.py”, line 243, in send_packet
File “dfu\dfu_transport_serial.py”, line 282, in get_ack_nr
nordicsemi.exceptions.NordicSemiException: No data received on serial port. Not able to proceed.

Possible causes:

  • Selected Bootloader version does not match the one on Bluefruit device.
    Please upgrade the Bootloader or select correct version in Tools->Bootloader.
  • Baud rate must be 115200, Flow control must be off.
  • Target is not in DFU mode. Ground DFU pin and RESET and release both to enter DFU mode.

Finally I found an article:

And it works!