Xiao BLE bricked after UF2 upload

I am currently developing a program for Xiao BLE nRF52 using PlatformIO.
I would like to send a dozen of boards to friends and am looking for a way to flash new boards without PlatformIO (so I can flash many boards in a row, and to let users re-flash without installing anything). I tried the following:

  • convert my bin program to UF2 with the UF2conv script
  • double tap RST on the Xiao
  • dropped the created UF2 file on the flash drive from my PC

this did not work (program was not launched on power-on) and bricked the device (no longer able to upload code from Arduino or PlatformIO)

I realize this might not be a Seeed Xiao specific issue but don’t know where to look.
Thanks in advance!

Hi there trth,
you didn’t include the softdevice in the programing of it perhaps. Also you may want to use
something like nRF Connect and the Programing tool.
GL :slight_smile: PJ

Thanks PJ,
Thanks for the pointers I haven’t tried nRF connect yet.
I was thinking that for end-users, updating a UF2 would be the easiest. Actually any solution where I can provide a zip file and an script / batch file where they don’t have to install anything, that would be ideal.

Sure thing, well if you use the programmer and include the softdevice , you CAN use the UF2 drop method AFAIK.
GL :slight_smile: PJ

Thanks again PJ, I’m just discovering what softdevice is, don’t quite get it yet. I found this page, is it relevant you think?

Edit: for reference I’m using https://github.com/platformio/platform-nordicnrf52/pull/151 in the xiaoble (not mbed) version

Hi there, sure just know it’s adafruit so they have there softdevice and bootloader. also
nrf connect for desktop (free) the programmer can show visually the physical layout of the flash too.
They have a utility forked from it as well.
GL :slight_smile: PJ
LOL, after you brick and revive your first one it’s all down hill from there. :slight_smile: :stuck_out_tongue_winking_eye: :v: