Xavier NX on A205 carrier board - problems flashing the OS image (SDK Manager stucked at 99%)

I am experiencing problems using Nvidia SDK Manager to flash the OS image on a A205 board with Xavier NX mounted.
We followed the instructions found on this link: A20X Carrier Board - Seeed Wiki
I tried the procedure both with SDK Manager GUI and with command line tool, without success. With SDK manager GUI, the interface keeps warning me that the installation takes too long and asks to continue (in a loop).
From the terminal, instead, the last rows of the log are reported below.

Any help, suggestion, guideline would be very appreciated. I’ll wait for your reply. Thanks in advance.

Setup:
Ubuntu 20.04 on the host machine
Jetson Xavier NX (mounted on carrier board A205 Seeed Studio)
JetPack 5.0

Last rows of the terminal
[ 9.5888 ] Sending bootloader and pre-requisite binaries
[ 9.5913 ] tegrarcm_v2 --download blob blob.bin
[ 9.5924 ] Applet version 01.00.0000
[ 9.6696 ] Sending blob
[ 9.6697 ] […] 100%
[ 10.6196 ]
[ 10.6233 ] tegrarcm_v2 --boot recovery
[ 10.6252 ] Applet version 01.00.0000
[ 10.7090 ]
[ 11.7142 ] tegrarcm_v2 --isapplet
[ 1012.6527 ]
[ 1012.6567 ] tegrarcm_v2 --ismb2
[ 2028.4606 ]
[ 2028.4675 ] tegradevflash_v2 --iscpubl
[ 2028.4694 ] CPU Bootloader is not running on device.

1 Like

Did you find the solution for this? If yes please share over here I’m facing the exact same issue.

I tried upgrading my Xavier AGX H01 to JetPack 5.0 via SDK Manager, and it does not recognize the board’s BSP, resulting in a similar error. NVidia claims that 3rd-party boards require their own firmware files. I see that Seeed has firmware for JetPack 4.6, but I don’t think they have 5.0 out yet.

Does anyone have an ETA on the 5.0 firmware?