Xavier AGX H01 flash problems

Hello,

I have recently purchased an Xavier AGX H01 kit, and trying to flash JetPack 4.6.2. I am writing this after 3 days of non-stop work with no success!

I am following the instructions given at Drvier Installation of Jetson Xavier AGX H01 - Seeed Wiki

(Problem1): In Step4, “tar xf” command is used for a zip file. This does not work ?

(Problem2): I tried the “unzip” command, and followed rest of the other instructions. After flashing the OS, it goes through timezone, username configuration. But then after the initial configuration is completed, the kit remains in “Recovery Mode” and there is no GUI output.

(Problem3): I tried to download the MIRROR FILE, indeed tried to download it multiple times. But it gives error messages, and does not decompress (Tried on both Ubuntu and Windows/7zip)

I have 5 Jetson boards, and have some hands on experience. I guess there are a couple of things that should be fixed. I will appreciate if you can provide clear instructions.

Thanks,

Hi

Same experience for me with 32.7.2 Drivers. Did manage to build and flash. Got through initial config then restart and OS will not load. stuck in boot screen.

Boot errors noted:
failed to load kernel modules
failed to start docker application container engine
failed to start nvpmodle service


mirror image will not download so i could not try that.

Dead in the water. Also looking for some help.
Thanks!

wiki works now. Thanks!

Hello @chilly,

I want to revive this thread as i have a problem with the USB drivers of the board.
In fact, i am able to reflash the board without any problem and i can get the GUI to show up smoothly. But a common thing to do once you are into the GUI is to apply some updates in order to stay compatible with all kind of different packages. And that’s where the problem occurs. After a regular “sudo apt update” and “sudo apt upgrade” and rebooting, none of the USB ports are working anymore.
This is linked to the fact that one of the l4t packages in charge of the USB controller is not compatible with the carrier board. Going from nvidia-l4t-xusb-firmware 32.7.1 to 32.7.2 seems to break the compatibility. Does someone have the same issue as i have ?
If yes, i would be so grateful if somebody could point me out on how to still have the updates via the package manager without breaking the board again :stuck_out_tongue:

Thank’s a lot in advance.

1 Like

Hey @Leon_the_pro ,

I don’t think there is driver support for 32.7.2 yet. I have requested it with seeed support.

I am pretty new so the NVIDIA course dockers will keep me out of trouble for some time and they run fine on .1

I’ll let you know if I hear back from seed support

any idea how to install jetpack 4.4 on AGX H01
I use SDK but no usb worked !!!