WM1302 starting problem

i set up wm1302 and raspberry following wiki instruction.
and i get this error:

Opening SPI communication interface
Note: chip version is 0x00 (v0.0)
ERROR: Failed to set SX1250_0 in STANDBY_RC mode
ERROR: failed to setup radio 0
ERROR: [main] failed to start the concentrator

someone can point what is not working properly??
This is my second wm1302 gateway,with the firstone i used the USB version and it worked properly. This time is the SPI version, i dont know if i should do something more than the recip i followed in the wiki…
spi comunications are enable, and reset pin changed to 25 and 17.then i generate the gateway in the platform and set up the conf file…

thanks in advance!!!

I have the same issue.
Looks like the pin definitions are not correct. I even cannot get meaningful responses to test programs querying the PSI bus

Baris DINC

Fully agree. The listed pinout in this document does not match the code block here:

# GPIO mapping has to be adapted with HW
SX1302_RESET_PIN=25     # SX1302 reset
SX1302_POWER_EN_PIN=18  # SX1302 power enable
SX1261_RESET_PIN=17     # SX1261 reset (LBT / Spectral Scan)
AD5338R_RESET_PIN=13    # AD5338R reset (full-duplex CN490 reference design)

I’m trying to make sense of the pinout diagram compared to the packet forwarder config but it does not make any sense to me at all.

Anyone from seeed that can help?

I found this post, but the changes don’t work for me.

Hope seedstudio team will look into this matter.

i have test this with the usb model and it worked fine but with this Spi model it doesnt work for me as well

I followed the wiki: LoRaWAN Gateway Module WM1302 - Seeed Wiki
And everything works as it should.

According to the R&D team, the “chip version is 0x00 (v0.0)” might be caused by the SX1302 not recognized. There are 2 possible causes:

  1. The hardware connection is not stable.
  2. “SX1302_RESET_PIN=17” was not set up correctly, leading to the SX1302 reset failure