WioTerminal RTL8720 update

Hello, According to your wiki we should be able to update the RTL8720 for eRPC features, I have tried several times to download the new firmware file but it is impossible the link seems to be broken.

Hi, this link is working here:

Well this zip file does not contain the rtl8720_update_v2.uf2 as mentioned in the wiki, I have also tried the ambd_flash_tool.exe with PS in windows 10 and got an error with the erase command. Well the wiki is particularly unclear.

On Overview - Seeed Wiki (seeedstudio.com)
The download of
works for me.
Please follow exactly the Video tutorial
(1) Wio Terminal Classroom with IoT #1 | Initial Setup and Scan - YouTube

I have tried several times and the download does not work for me. I use Chrome under W10 I do not understand.

Firewall ? Virusscanner ?

You can try from my Google Drive

Hi @guideon,

You can only erase the firmware when you see Burn RTL8720 fw on the Wio Terminal LCD, after copying rtl8720_update_v2.uf2 into the Wio Terminal.

Please follow the wiki or the following videos carefully:

Also, check the this link to my drive. I have included rtl8720_update_v2.uf2 and 20210108-seeed-ambd-firmware-rpc-v2.1.1 files.

Best Regards,

I have a little white brick on my desk- I have tried to burn with the update on Lakshanthad’s one drive, what do I do?? This has been quite a bad experience TBH.

@David_Hancock, don’t be sad. Many others were able to successfully update the firmware. If you want others to help you, please describe exactly what you did and where the Wio Terminal didn’t behave as espected.

I followed the instruction, enabled the boot loader and dropped the file on to the drive- as soon as I did that the unit displayed “burn RTL8720 fw” the display has not changed(I left it on over night).-What do I do?

Hello David,
what you saw is the ‘normal’ behaviour after the firmware update. Please see in this link how to proceed.
-Incomplete steps! Wio Terminal Network overview

To get out of the “Burn RTL8720 fw”, you simply need to reset the Wio Terminal by sliding down the left switch twice in quick succession. Then just upload any code into Wio Terminal using Arduino IDE, and that code will be executed.

Hi everyone!

We have changed the RTL8720 firmware flashing method and updated the wiki as well:

Please follow the steps carefully to flash the RTL8720 firmware to Wio Terminal.

Now we have omitted the steps of uploading the .uf2 to Wio Terminal to enter flashing firmware mode, downloading the latest RTL8720 firmware from GitHub and combined all the steps into the ambd_flash_tool.

So, now you only need to use the ambd_flash_tool to flash new firmware to Wio Terminal!

I will prepare a video as well and post on Seeed YouTube to walkthrough the steps.

Furthermore, we will add all the WiFi-related libraries to Arduino Library Manager , so that it will be more convenient for you all to search and install the libraries from Arduino IDE, rather than downloading and installing them separately from GitHub.

Hope you all like it!

Best Regards,