Wio Terminal Code Craft Upload Failed

Hi all, I just got my wio terminal. I would like to try out the Tiny ML features. However, even for some simple example, I can’t get the “default data collection sample program” uploaded.

It can detected the Serial Port.

Did I miss anything? Thanks!

hello, I’m glad you’re experiencing our new features. Can you tell me if you are using Windows or MAC? What is the system version? And a software version of codecraft’s assistant. If you can attach pictures or videos of failure, I can help you solve the problem more quickly.

Hi, I am using Windows 10 system.

Edition Windows 10 Home Single Language
Version 20H2
Installed on ‎18/‎7/‎2021
OS build 19042.1110
Experience Windows Feature Experience Pack 120.2212.3530.0

You can find the videos of failure here and code craft assistant version: https://youtu.be/THBuNuLg824

Thank you!

Looks like the compiler on your equipment failure, now we have the latest version of the solution to this problem, you can download the latest version here v2.7.0.4 (https://ide.tinkergen.com/download/en/)

1 Like

If you see my video, I am actually using v2.7.0.4 and it is still failure.

Please try to switch the device to “Arduino”. Is uploading the program again successful? Also, do you have any error messages or warnings when installing theCodecraftAssistant?

1 Like

Hi, switched to Arduino, and it was failed to upload as well. I have turned off my laptop’s firewall as well. So far, when installing Codecraft assistant, there is no any error messages or warnings. I can’t figure out what’s wrong with my device. Please help.

Even I tried download the PC version of Code Craft, I can’t upload to Arduino UNO.

Please try ardunio IDE to upload Blink program. Is it successful?

Hi, Arduino IDE blink program is successfully for my Arduino and Wio Terminal.

I tested it on a win10 home version of the computer, and did not find the same problem as yours. In order to learn more about the error, we will add a log function to CodecraftAssistant. I will contact you later

Now that codecraft supports viewing logs, please restart your CodecraftAssistant go to https://ide.tinkergen.com/ update and provide me with the error message.

Hi @Chunchun, now it worked! Thanks for the log features that help debug this issue. The issue is due to my username on laptop is with “space” (Vincent Kok), hence I changed the username to without space and it works fine now by upload successful the data acquisition code.

Thanks! image

We will fix this in a later version update. Have a good time!