WIO-E5 keeps crashing after flashing and running

Hello All…
I am new to LoRaWAN and hoping someone can help me here. I have a WIO-E5 that I put down on a small PCB with castellations. I took the code from

github code

and am using the directions on Seeed website:

Seeed website

I am using US915 and this is a non AT command end node. I want to connect to my gateway and see that my WIO-E5 can take code and send something to the network. Using the above procedure for Lorawan End Node I am having no luck seeing my device on the TTN. The CubeMX Programmer says download verified successful. I then DISCONNECT the debugger and press the reset button but see nothing…

If I go into CubeMX IDE I download code that way and hit run and I am constantly getting the message returning on the IDE console:

Target is not responding, retrying...

Using a breakpoint I am finding that the following line of code is causing me problems:


Can someone tell me what I need to do here? I was hoping this would be straight forward as I would like to get the board up and running on TTN then play around with code to learn LoRaWAN…

any help would be great!
Thank you

had you setup and tried your E5 module on TTN network before erasing AT firmware ? Also is it properly registered on TTN and are you sure you are in an area covered by TTN ?

Hello vincen…

  1. No to the first question HOWEVER I do have a Lora-E5 dev board (obviously this is different) that I tried the AT commands on and it did appear on the TTN…

  2. I “believe” it is registered properly…

  3. Based on answer 1 above yes I have a gateway that is registered and able to feed data to the network.

The issue I am having is running the code with debugger connected and getting Target not responding message on the debug console in parallel with nothing showing up on the TTN network…I am presuming that the two are related and something is wrong with compiling and why I am getting the message in the console


Thank you

Yep looks like to be an issue of communication between debugger and target but I won’t be able to help you on that, I gave up while ago when I tried to setup/use the ST IDE for programming these chips, I’m probably dumb but it’s just a crazy nightmare not even speaking of need of a specific interface (STLink) to connect to it ! looks like electronics from 70’s :frowning:

If you have the debugger connected and the code tries to sleep or similar you’ll get this error. Without the debugger running it’ll run just fine but with the debugger going it won’t. So, if you “run” vs “debug” the code it’ll download and run and you’ll get that error — but once the error stops the debugger will disconnect and you can reboot the board and the code will run fine - you just can’t debug it with those particular commands. Some of the apps have a define to turn off the sleeping stuff.