Lora-E5-HF Not connecting to UART

I have created a carrier board for the Lora-E5-HF…see schematic below

Using RealTerm 9600 I connect to Port 10

Using the wiki I send AT but get no response back…I have tried two boards and get the same response…I have a third board and was able to reflash it with code so I know the PCB is good…
This is the first time I tried the AT stuff…Be advised C5 and C4 are Do Not Populates. Any ideas or what I can try??

Does it Loop back? Any hardware flow control? What happens if you try and connect to the others?
At should get you an “OK” unless it’s in no echo mode ??
Try different ports first and be sure the Terminal loops back and echo’s what your sending. to start
GL :slight_smile:

Here is RealTerm settings:

I believe all is good…I have used this on a Lora-e5 development with success

I would like to add the following to the case here…Firstly I am able to get STM32CubeProgrammer to connect to my device so I know that it is wired correctly. My setup is CubeProgrammer through STLINK-V3SET to board…The Programmer ONLY connects (after a board power up) if you hold Reset Button down Hit Connect on STM32CubeProgrammer then release Reset Button on board…(Why doesn’t SEEED documentation state this anywhere)…After finding this I get the following but by dismissing the error I now see I can change the RDP level to 0 if I want AND further I see the STLINK is connected.

Now if I acknowledge message change STLINK to UART (upper right hand corner and try and connect with the settings you see) I get the error below

Can someone tell me why in both STM32CubeProgrammer and RealTerm I cannot connect to the UART??

Hmm, seems as though it should work, Can you check the TX & RX on The chip Maybe swap them. Also Is this PB0 Grounded maybe? I’m not familiar with the STM32 Cube but sound similar to the ESP-PROG.
Your Terminal Looks correct, should see the Status flash on the 2, 3.
You are close, Serial port or boot mode issue for sure. WHAT IF you HOLD boot button down ?
I don’t see any serial port GND anywhere either? May want to try a pin 7 to pin 7. Terminal to Chip GND
ALL 5 V devices and setting ?
USART ports BTW:
9 PB7 I/O UART1_RX from MCU
10 PB6 I/O UART1_TX from MCU
More study… on this end.
GL :-p

You have been a big help!..Sometimes it just takes a second set of eyes…I am used to using dev boards which typically pass a UART over the debugger port as some sort of Virtual Comm…Now it is a matter of finding which UART port to connect up. Based on Seeed schematics of Lora-E5 development kit I presume the port is PB6/PB7.

I am only doing this to validate a Lora link with my spun PCBs to my gateway and to the TTN. To close the loop I really want to erase the AT firmware and place Lora-End_Node code on the board. I posted a link on this, see below. Would you have any insight here?

Lora-End-Node code instead of AT

Thanks again for the clarity above!! I will get a usb/uart and try this…

1 Like

I’m soon to get a set to try so I’ll be more in the know soon, But Are you silly question "holding the reset button Down, Then hit connect on the screen , Then let go of the reset ? My .02?
(I’ve seen the end-2-end done with the BLE modules, same thing replace the AT-firmware with Master slave only functionality. Those JDY’-0010,etc)
Your Close but I wonder how up to date the seeed and platformio stuff is??

GL :slight_smile:

To clarify all:
USB to UART converter wired to board and all now works fine…ie I see device on TTN and can send mssgs.

with respect to the programmer…Yes you are correct I hold reset, hit connect on the application and then release reset

Nice work, I knew you were close…
GL :slight_smile: