Wifi power saving causing high latency

1. Running the latest available image (20180801)

2. Connected to my wifi successfully

SSH is VERY latent. Pings are all over the map. Upwards of 2 seconds some times to dropped packets others

Running “/sbin/iwconfig wlan0 power off” brings things back into working order. Pings drop down to 10ish ms and SSH is MUCH more responsive.

Only problem is the normal ways of disabling power management on the wifi card (like adding wifi.powersave = 2 to the NetworkManager config file for the connection, or scripting iwconfig in /etc/network/if-up.d to disable power) doesn’t seem to work. Power management is disabled initially, but then is re-enabled somehow by a “yet to to be found by me” way.

If I brute force it by doing
</s>sleep 10 /sbin/iwconfig wlan0 power off<e>

In /etc/network/if-up.d/wifi-powersave then things are better. But it seems like I shouldn’t have to sleep like that.

Just thought I’d report here on this. Let me know if you need any more info.


Hi Chris,

I use the 8.01 SD image and use the SSH, Here is my test result. it looks normal.