USBCAN analyzer does not work

Hi there,

I purchased CAN BUS Analyzer (part number 114991193) from Digikey. The sticker on the product shows the product name is "USB-CAN Analyzer (V8.00).I came to SEEED website and downloaded the driver, the program, the documents, and instructions.

I installed the driver for USBCAN (CHS40), and run the program USB-CAN(V8.00).exe. I read the 2nd document “2.USB-CAN converter self-test.pdf” and try to perform the self-sending and self-receiving.

I can see the COM port, change baud rate, open the COM port. I selected "Loop back + silent "mode, clicked “Set and Start” button, and clicked “Send a single frame button”. However, I could not see the Send LED blinks, nor Rev. LED blinks, indicating that the data actually didn’t send out, no data received either. On the screen, the program shows only Send data, but no Receive data.

I tried restart my windows 10 computer, restart the program, and send again and again, but they are all the same. No LED blinking, no data received, nothing happed.

Please let me know if this means the product is damaged. If so, I can ask a return to Digikey.

Or, if my steps are wrong, please correct me.

Thanks a lot!


Hi there, And Welcome.
May I ask What Baud rate you set?
Do you have picture of the setup wiring?
GL :slight_smile: PJ

I use 115200bps for the COM, and 250Kbps for the CAN. The screenshot is attached.

I didn’t make wires. I just tried self-sending and self receiving.

The Send LED does not turn on when I press “send a single frame” button.
Then the Rev. LED does not blink either.

Does it Flash when you connect the USB cable?
How many times. or when you Boot computer?
You have the jumper installed?
GL :slight_smile: PJ

Both LED flashed when I plug the USB cable, every time.
Yes, I have the jumper connected.

You have to set the Baud Rate ,The default is 2000000 ? if I recall, then select 115200 and hit select if I remember.
Then do the self test it will work , you almost there.
GL :slight_smile: PJ

let me re-plug the USB, and re-start the program and try it again.

Oh yeah, it works. Is it works at only 2000000 baud rate?

And, the Windows Device Manager says the baud rate of COM port is still 115200bps. Should it be set to 2000000bps by the program ?

Hi there,
Yea you see the Change Bps button , you can set it to what ever and windows will go there.
GL :slight_smile: PJ :v:

Please be sure to mark as Solution so others can find the secret handshake :smile: :fist_right: :fist_left: :handshake:

OK. 115200bps works as well. So I think it may be a software bug. So we have to click the pull-down window and do the real selection on baud rate, then click “Open” button, the baud rate will be settled. The program will not select a baud rate automatically even a baud rate number is shown in the window.
May be this is the reason.

But it works now! Thank you very much!

No actually it’s setting it CORRECTLY the first time as I showed You.
GL :slight_smile: PJ :v:

Yes, I agree with you. I think it is my mistake for overlooking the power-on LED flashing count. The LEDs flash only once when it powers-on at first time, so the serial baud rate is 2000000bps by default. I should set the baud rate to 2Mbps accordingly.

When I changed it to 15200bps, the LED flash 3 times when it is power-up. Now I am working with this baud rate. As I use this USB-CAN converter more times and read the 1st document, I realized the LED things. And every time I change the settings, the red LED will flash once, I believe this is the sign of successful setting change.

The converter and the software actually works well. I also use it for normal communication.

Thanks PJ.

1 Like