USB Serial Port Not Recognized on A603 Carrier Board

I followed the link to flash Jetson Orin NX on the A603 carrier board.
Link: A603 Carrier Board | Seeed Studio Wiki
I flashed it with JetPack 5.1.2 version, and everything flashed successfully. However, after connecting a USB device, the /dev/tty* port is not recognized.

When I run lsusb, the USB port seems to be working fine, as it is detected. The device I am trying to use is an IMU sensor receiver, and lsusb shows it as Silicon Labs CP210x UART Bridge.
I have tried various solutions through extensive research:

When I run sudo modprobe cp210x, I get the error `modprobe: ERROR: could not insert ‘cp210x’: Exec format error.’
Downgrading to JetPack 5.1.1 resulted in the keyboard and mouse not being recognized for some reason.
Reinstalling JetPack 5.1.2, the keyboard and mouse work, but the USB port is still not recognized.

when i unplug and plug the cp210x device, the output of ‘dmesg --follow’ comes out like this

[ 286.050833] usb 1-2: USB disconnect, device number 5
[ 290.897511] usb 1-2: new full-speed USB device number 6 using tegra-xusb
[ 291.051110] usb 1-2: New USB device found, idVendor=10c4, idProduct=ea60, bcdDevice= 1.00
[ 291.051121] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 291.051126] usb 1-2: Product: CP2102N USB to UART Bridge Controller
[ 291.051129] usb 1-2: Manufacturer: Silicon Labs
[ 291.051132] usb 1-2: SerialNumber: 0001
[ 291.075503] usbserial: exports duplicate symbol usb_serial_resume (owned by kernel)

what could be the problem?

I’m getting the same issue with an FT230X converter chip. Shows up in lsusb and usb-devices but does not get assigned a /dev/tty* descriptor as expected. Running a similar modprobe command gives the same result. I tried downgrading to jetpack 5.1.1 as well to no avail.

$ sudo modprobe ftdi_sio
modprobe: ERROR: could not insert 'ftdi_sio': Exec format error

Any help is appreciated!

Try to remove the file usbserial.ko in the below directory.

sudo rm /lib/modules//kernel/drivers/usb/serial/usbserial.ko

This solved my error.

That fixed it! Thank you very much.