Unable to enter storage/bootloader mode on Vision AI Module v2

Hello,

I can upload a preset model using SenseCraft web toolkit and that works fine. However I can’t upload my own model (in uf2 format) because I can’t put the module into storage mode. I’ve tried Method 1 and Method 2 (described here), on Windows and macOS, with and without the driver installed, with a few different cables. I haven’t been able to make the module appear as a storage device so I can copy the UF2 file over. What am I missing?

Thanks,
Daryl.

Perhaps someone from Seeed could comment on this. I was excited to hear about this module so it’s pretty disappointing to have a basic issue like this.

Hi there,
I have not received my Unit (won on live stream ) Yet, but by chance do you have a Xiao mounted?
I the upload that worked, was it in Windows machine or MAC?
If windows , I would stick with Unplug , hold boot button (white one) & replug into USB,
If it enumerates, great , may need to try it a few times…
for normal boot mode drive available hold boot button while connected and Tap Reset button.
YMMV,
HTH
GL :wink: PJ

Hi PJ,

Thanks for those suggestions. I don’t have a Xiao mounted. For the uploads from the SenseCraft web tool I was using macOS. That worked fine for the canned models. No luck for mounting it as a drive though.

Daryl.

Hi there,
Sure, High anticipation on getting the free unit :blush:
Have you tried HOLDING The RESET button for a LONG,LONG Period?
Hail Mary…
GL :slight_smile: PJ
What model did you initially use?

Yes, I held the reset button for 30 seconds while also holding the boot button. No success. Other microcontollers I’ve used (Pico, Feather, Arduino) are easy and quick to mount.

The canned models I tried were the rock-paper-scissors detectoor, pose estimation, and face detector. There’s no problem with those. They aren’t useful for my intended purpose unfortunately.

1 Like

I’ve a issue while attempting to upload my own model in UF2 format to my device using the jolly kids meal web toolkit. Followed the provided instructions and trying various methods, including both Method 1 and Method 2, my device simply won’t enter storage mode. I’ve tried different cables, checked compatibility, and even attempted the process on both Windows and macOS, but to no avail.

Hi there,
Can you post a picture of both sides?
Thanks.
GL :slight_smile: PJ

Hi everyone

Currently the only interface for the Grove Vision AI V2 to upload models is the Sensecraft AI platform. See this wiki for how to upload models:

For the ‘Boot’ mentioned in the wiki, if you are using some unusual method that makes Grove Vision AI not work at all (at the software level), then you may need to put the device into BootLoader mode to revive the device. This ‘Boot’ is not used as an interface to upload your uf2.

Thanks for your reply @Seeed_Seraphina. The pre-canned models in SenseCraft work fine. I’ve tried uploading custom tflite models exported from Ultralytics YOLOv8 using the command:

yolo export format=tflite model=yolov8n.pt imgsz=192 int8=true half=true

but always get the “invoke failed” error.

What is the model size limit for the AI v2 module?

At the moment, SenseCraft AI does not have the capability to upload custom models from users. However, our dedicated team of engineers is diligently working on developing compatibility for this feature.

1 Like

Ok, thanks for the update. While the team is working on that, making available in SenseCraft for the AI v2 module a pre-canned YOLO model trained on COCO would get my vote.

1 Like