Tutorial: How to flash/debrick/update DFU on DSO203 HW V2.81

To get this straight. This method will work with older hardware versions, but the DFU linked will work with HW v2.81 devices and probably all the other 8MB versions (like v2.72).

This tutorial will cover how to flash DFU firmware, and unlock the device with the proper license. Also this fixes the DFU drive issue under Windows 8 / 8.1 /10 for DFU versions 3.40C and lower. This is done by updating the DFU to v3.45C.

Firstly you need to get a note of your licence number. Boot the DSO into DFU mode and write it some place safe:

In case your device is bricked and don’t know your license number, don’t worry. You should be able to get your serial number after de-brick and you can kindly ask in the forum here about your license number:
minidso.com/forum.php?mod=fo … lay&fid=54

Make sure you have a working USB to SERIAL (RS232) adapter that supports TTL levels 3.3V. This means you have installed the correct drivers and it is working under your OS. I’m using a genuine FTDI FT232L usb to serial adapter. This one has adjustable TTL levels so make sure you set the jumper to 3.3V:

Now disassemble your device. It has just 4 allen screws in the bottom. Unscrew them and taking the backing plate off:

Then you can either disconnect the battery to help you take the board out (and prevent any accidental shorts) or you can leave it in (because we’ll need to attach it back on later). To pull out the board you need to lift it from the bottom, and then draw it outwards. The power switch and/or buttons may fall out but it’s really easy to put them back on later. I found pulling it up from the bottom right corner with a flat screwdriver to be the easiest.

Now get some jumper wires and connect as follows:

Number 1 is the pad with a square shape.
Connect as follows to your RS232 adapter:

-PIN 1 jumped together with PIN 2
-PIN 6 connects to GND of your adapter
-PIN 4 is RX so it connects to TX of your adapter
-PIN 5 is TX so it connects to RX of your adapter

If you find later that you get no response, try swapping pins 4 and 5 RX<>TX.

Make sure that the jumper cables you used don’t protrude all the way through and touch the shield! This will cause a short to GND and you will not get it working.

Now is a good time to plug the battery back on if you had it disconnected before. Power up the device, and if there is a white screen means you are good to go!

Continuing now please download and unpack my archive. It’s a rar file so you’ll need winrar or another suitable program to extract it (duh…):

dso_hw281_dfu_pack.rar (6.56 MB)

Now install the Flash_Loader_Demonstrator_v2.5.0_Setup.exe. This is the flasher we are going to use to flash the new firmware.

Launch the flash loader, select the correct COM port of your RS232 device and press next. If it all goes well it should detect the STM32 processor (512K). Press next through the screens until you go to the screen where you can select a file to download. This is good chance to upload the DFU firmware from the device to keep as a backup in case you mess something up. I uploaded mine from the device 2 times and compared the hash to verify it. I have also included it as DFU340C.hex in the pack in case someone needs it. Now select DFU345C.hex and download it to the device. Do not touch anything! Just leave it there to do its job! If you accidentally disconnect something you’ll need to repeat the flash process. It takes about 5mins to download, please be patient:

Now if all went well, you can power down the device, disconnect the jumper cable between PIN 1 and 2 and power up the device. You will get a license error but check if everything works. Now is a good time to get your serial number if you lost your license number and ask for it in the forum link i gave above.

To unlock your device now you’ll need to re-connect the jumper cable and go again through the same process and flash UNLOCK.hex . Now when you boot back again you will be prompted to input your license number:

Once finished, you’ll need to re-flash the SYS file through the DFU disk mode of the DSO203.

Assembly is the reverse of disassembly, so put back everything together and your DSO is ready to GO!

Thanks for the detailed post. I saw another similar bootloader how-to, but I don’t think they ever addressed the 3.3v TTL levels on the programmer FTDI. When you power up the DSO with the 1-2 jumper installed, what is shown on the LCD? Bootloader mode?

Also thanks for the bootloader attached files. Can you provide the attachment in ZIP format? I don’t want to have a RAR extracter. RAR compression is obsolete, as ZIP has been built into Windows for a long time.

I registered with MiniDSO forum, but never got the email to validate my account. Nothing in my Spam folder. So I can login, but can’t post or send PM. Can you send them a message about me being locked out? I used the same UID: borland

It’s just a plain white screen as you see in the pics above. This is due to basically connecting directly to the processor, DFU is the bootloader; with this way you essentially bypass it. Similar deal when you flash Atmel microcontrollers in Arduino using ISP. Make sure you use TTL levels, and while some other electronics are 5V tolerant i’m pretty sure the STM processor isn’t!

Yes i’ve done it…but really winrar and the rar format is so much better than zip…
dso_hw281_dfu_pack.zip (6.8 MB)

Have you tried registering which another email? I use gmail and the registration email was placed in the SPAM folder so have a look because i really know no-one to contact. Also try using the forget password link.

I made up a jumper for my FTDI programmer relying on my memory of your photos. After I finished, I looked at your photo again and not sure if it will work.

Is the PCB pin spacing 2.54mm (0.1 inches)? In your photo, it kinda looks like the jumpers are spread apart. I used a single 6-pin dupont housing.

I had already tried all those ideas for getting activated on miniDSO forum. It’s a catch-22. I only have one email account that I can give out.

Thanks for the ZIP.

Not sure if it will work? Test it. If the flasher programmer detects the processor you are good to go!

I used a dupont housing myself at the start…then found it didn’t fit. The pitch is smaller than the 2.54mm so i used individual pins at an angle instead like in the pics.

I checked to find an admin in the forum to contact about you but it’s all in chinese:/ Try doing a gmail account:)

Thanks. The pin spacing 2.0mm. I made an adapter by soldering together 2.0mm with 2.54mm headers.

Nice work:) I need to purchase some of these headers and pins to have on hand next time:)

the tutorial I made several months ago also may be useful…
docs.google.com/document/d/1KtI … 5q7Is/edit

Finally had a chance to update my Quad. A comment regarding the procedure…

The baud rate needs to be set for 115200 versus the default of 57600. Otherwise the upgrade for the DFU went fine.

Unfortunately Win10 does not recognize my Quad. Went to my Win 8.1 machine and everything was as it should be.

Wildcat 4.4 running great!!!


Hi guys, just one more thing from me, I had to tick “Jump to the user program” during UNLOCK.hex flash. Otherwise my device makes only beep sound. When I checked “Jump to the user program”, it asks for license key, but unfortunately no one replied on my post on the forum :frowning:

Link to my post http://www.minidso.com/forum.php?mod=viewthread&tid=1024&extra=
plz help…

I still don’t understand why there’s not key generator and documented everything on wiki, as they did for all previous versions.

Your tutorial was a great help. Thanks!

I re-flashed mine without ever disconnecting the battery from the circuit board. Also used masking tape on the outside of the case to hold the four buttons in place, and also to hold the power switch button; this made reinstalling the circuit board in the case much easier.

I also went from DFU 3.40C to DFU 3.45C. For “Download To Device”, I selected radio button “Erase necessary pages” instead of “Global erase”. Also, I check marked “Verify after download”.

After downloading the DFU 3.45C hex file, I used the flash software’s “back” button and immediately downloaded the UNLOCK.hex file. I then re-assembled everything before powering it up and entering the license key.

After the DSO accepts the license key code, it reboots and says to place the unit in DFU mode and reinstall the SYS file. In DFU mode , my Window 10 recognizes the DFU drive, so I copied SYS_B164.hex to it and got the normal “rdy” file name extension.

I thought I was ready to go, but the old factory app came up with a reboot. So, back to DFU mode, and reinstall Wildcat version 4.5.

The 8MB drive is still as before, so none of those file were lost. Glad the DFU mode now works with Windows 10.

Didn’t need the LOGO or FPGA adr or bin files. Not sure what those do, but apparently they are not needed.