Trouble putting CircuitPython on XIAO ESP32C3

I am still not sure how or if the XIAO ESP32C3 is actually ready for CircuitPython. Discord for XIAO seems to imply yes. Plus, I found the latest CircuitPyton “.bin” for XIAO ESP32C3. Mixed online help for ideas to get it on the device!
I used the recommended espriff to place the CircuitPython latest “.bin” on the device. Seemed upload fine. But cannot place any libraries cause I cannot find it - NO Drive shows up. Then connected a USB to UART device. Still no way to load libraries or projects! Open MU and tried to load the same “.bin” and just get an error uploading. It seems to start with ……
Then tried micropython’s latest “.bin” same thing. Then found something saying I have to install espressif-ide. Have not done this until I know for sure that is what is required.

Some how I am not getting it. Arduino is easy and works great. Trying to use CircuitPython. Is it not ready - no instruction on SEEED wiki.? If it is, please provide a link to how to make it happen for a beginner+!!!

Same here. New XIAO ESP32C3, flashed latest circuitpython with esptool, no drive mounts (Windows 11).

Unfortunately after spending long hours at this issue, I have learned that the ESP32C3 does not support USB drive functionality. To get code and libraries onto the board, there are alternative methods to transfer files which I will reference bellow.

Thank you. I since decided to use the several ESP32C3s for Arduino projects.