The Xiao ESP32C3 SPI does not work with TFT Display and touchscreen

None of the SPI TFT examples w/touchscreen work on this board. The SPI is hung-up until I disconnect the MISO.

I may be experiencing the same thing using GitHub - adafruit/Adafruit-ST7735-Library: This is a library for the Adafruit 1.8" SPI display and the screen boots white, but apparently receives no instructions. It stays white.

If you see errors like “Failed to connect” then your chip is probably not entering the bootloader properly:

Check you are passing the correct serial port on the command line.

Check you have permissions to access the serial port, and other software (such as modem-manager on Linux) is not trying to interact with it. A common pitfall is leaving a serial terminal accessing this port open in another window and forgetting about it.

Check the chip is receiving 3.3V from a stable power source (see Insufficient Power for more details.)

Check that all pins are connected as described in Boot Mode Selection. Check the voltages at each pin with a multimeter, “high” pins should be close to 3.3V and “low” pins should be close to 0V.

If you have connected other devices to GPIO pins, try removing them and see if esptool starts working.

Try using a slower baud rate (-b 9600 is a very slow value that you can use to verify it’s not a baud rate problem).

Rachel Gomez

@rachel_gomez your response seems to belong to a different thread?

@jbierlink indeed, my new TFT wasn’t working with the XIAO esp32c3, so I tried the same sketch with an Arduino (only modifying pin #define macros as appropriate) and it worked to drive the same TFT over SPI. I have no plans in mind to investigate why it’s not working :frowning: