Temp & Humidity Sensor Pro


I have had Raspberry Pi in the past and enjoyed them. But I am still not great at understanding how to work with the GrovePi+. I currently have a Raspberry Pi 3 Model B with a GrovePi+ and a Temp and Humidity Sensor Pro.

I followed the setup instructions:

<LINK_TEXT text=“http://wiki.seeedstudio.com/Grove-Tempe … spberry-pi”>http://wiki.seeedstudio.com/Grove-TemperatureAndHumidity_Sensor/#play-with-raspberry-pi</LINK_TEXT>

When I run:

sudo nano grove_dht_pro.py (in the terminal)

I get a GNU nano 2.7.4 File: grove_dht_pro.py

And it is just a blank black screen (Also says New File at the bottom)

The very first time had licensing text and links to the above weblink I have provided and this forum.

The code shown in the next step:

import grovepi

import math


Did not show up in the terminal like I had expected it.

When I tried running this code in the PythonIDLE it said “No module named ‘grovepi’”

Am I supposed to be running this code in a different enviroment? I am not sure which one. It looked like python code to me.

Please help I would like to start gather data from the sensor

Thank you,


HI Nicholas,

  1. which folder do you locate when you run “sudo nano grove_dht_pro.py”?

    the python file is located at ~/GrovePi/Software/Python. please do make sure you go to the folder first before editing the grove_dht_pro.py.

  2. for the “No module named ‘grovepi’”, please follow <LINK_TEXT text=“https://www.dexterindustries.com/GroveP … -software/”>https://www.dexterindustries.com/GrovePi/get-started-with-the-grovepi/setting-software/</LINK_TEXT> to configure the development environment. you can follow the Quickstart Directions as below.

    In the command line, type the following commands:

    sudo curl -kL dexterindustries.com/update_grovepi | bash

    sudo reboot

    After your Raspberry Pi reboots, the GrovePi is ready to use!

    We hope it can help. thanks.