Skyconnect drivers

I tried installing this on my win 11 PC. Doesnt seem to install drivers for it properly. Where do I manually download the drivers since it gets recognised as something else.

HI, here is the official driver for this device, you can go and install it manually and you will see it in the device manager after the installation is completed

It does instal as Silicon Labs CP210x USB to UART Bridge but I thought its meant to be recognised as Skyconnect. Also I cant see it when I go to Homeassistant > Devices > Add devices > ZHA list

1 Like

You can try reinstalling it, it looks like your device is incorrectly identified

yeah same thing I see as well but when I go to HA I am not sure what I should do


If I choose the first one(hopefuly correct)
then I get

So it’s still not available?

No dont think so. I have seen some videos on youtube where the reviewer had it identified as Skyconnect something bla bla…

This is a brand new HA intall on my Windows 11 machine in VirtualBox

1 Like

We have only used homeassistana on the Odyssey linux, we suggest you look for answers at homeassistana

Ok worked. Added it to the VirtualBox USB items and then it popped up

I know this issue is resolved but in case anyone else runs I to it you can find the serial device path in HA by going to settings > system > hardware. By default, it should be /dev/ttyUSB0 for the SkyConnect serial path.

When you go to hardware with the SkyConnect, you will see a configure option. Unless you have actual Matter devices I highly recommend NOT setting this up and just ignoring it. Originally I checked it and had to reset it to get things working. Simply put Matter isn’t ready yet and if you are using the SkyConnect for just ZigBee there is no reason to setup experimental features. It can be recognized at a later time when Matter devices are more widely available and they work out all the annoying first gen issues. That way you can use ZigBee and Matter with the SkyConnect.

Outside that the default settings should work.


I seem to have activated the “experimental features” and can’t undo it?
Do you have an idea what I can do now?
I use Windows 11 with VMware and Home Assistant.

I tried going back but didn’t work. Gave up. Seems to be working ok.