Seeeduino xiao won't reset or program

Hello, I was programming my xiao just fine before but now the com port is gone and the board won’t reset when I jump the reset pads. The power led turns on and my computer recognizes a device being plugged in but there is no com port and nothing happens when I jump the reset pads. Is my board dead or is there something else I can try to fix this? Thanks!

What happened before that?Are there any circuits connected to the exception?

I had it driving an adafruit TFT. I hadn’t changed anything about the circuit and it worked great before. I power cycled the board to reset my code when it stopped working. I checked the device manager on windows and there is no sign of it anymore. I read on other forum posts that I may need to reflash the bootloader but I don’t have the tools to do that. Is it bad to unplug it and plug it back in a frequently?

I’m worried about a wiring problem that short-circuits the CPU.

I don’t think I did anything to short the processor. I hadn’t changed any of the wires and it worked just fine before. The power led still lights up when plugged in. I took the board off of the breadboard but it still doesn’t reset. Is there a way I can test if the chip is still alive? I can try using a multimeter on some of the pins to see if there is any voltage coming out of them.

This bare PCBA equipment, sometimes static electricity can also cause damage.The led light on the top only means the USB is powered on.

Roger that. If you think it’s dead, I guess I’ll just try another board from the pack of 3. Going into the future, is there anything I can do to prevent this? (Other than obvious errors in wiring up circuits). Or did I just get unlucky with mine?

I have had two devices fail. On both occasions, the Xiao was soldered to stripboard and each device was checked for functionality before adding the next (microphone, switch, potentiometer and led). On the first board, all worked then the following morning, the board would not work. Just finished a duplicate board, again checking every device before adding the next. Again the board died. No success trying to reset. Very disappointed and too unreliable to use any more.