Seeeduino XIAO SAMD21 Breaks When Powered by 220v Source

I am currently reviving a Neopixel project on my SAMD21 board, and have changed countries from 110v source to 220v wall power. When updating arduino code with a direct connection to my computer, the XIAO works fine, and shows the changes to my code.
I am using a long Neopixel strip and notice some issues when making the strip brighter, so I decided to power it using a 5V 2A phone charging brick. However, when I did this, the Neopixels no longer lit up. The XIAO still connects to the computer and the green LED on the board still turns on, but none of the strip responds. This happened again when I connected a second XIAO to a different charging brick with the same end effect.
I checked the strip and do see 3.3v coming through the strip using a multimeter, but I cannot tell if the strip is receiving data or not. Please advise.

Have you tried simple sketches like “blink” for example to check if XIAO is broken?

Yes, it is recommended to check that your XIAO is working properly, you can upload some simple programs, and check Neopixel’s circuit connection

I have tried “blink” and the onboard Neopixel does respond, but when I change the data pin from the onboard (12) to the pin I am using (I tried both 10 and 0), the Neopixel strip does not light up.

stopped being recognized by the usb port… others are being recognized so i am assuming i fried it somehowit seems to be getting usb power with green led but i cant tell if anybody is home… any ideas?

If your XIAO is SAMD21, have you tried “double reset”?

Yes and No… i dont know what double reset is, can you explain

See “Enter bootloader mode”

wow thanks, but what is odd, is i had two which were bricked… one bricked a while ago and i assumend it got static shock and threw it in the coin jar… the second bricked and i write the post about

i short the newist and it didnt work so i tried the one from digging out the coin jar and wow it works

so i started with two and now have one, both have green on power and no usb but the second one did go to green and connect after shorting out… any other sudgestions?

interesting, it also appears if you have the xiao expansion board you can double click the reset button to achieve the same result… but it seems this didnot help my one bricked unit


Try the links below.

yes thank you i was looking at the raspberrypi version and i have a zero, but it has no pins souldered so i was wondering if the expansion board and an ftdi or other arduino could do the job… if you are with seeed can you see if this makes its way to the wiki

thanks again for your help… i will probably start on implementation tomarow

ok thanks for help
i was unable to understand the path for the flask.bat
i think part of the problem is microsoft onedrive messes with file structure

i find the example to drag and drop the simple_daplink_xiao.uf2
to the daplink xiao via double click reset method as described

this worked and i get the double blue led as someone else said
i have the setup to xiao expansion board and green light on bricked

how to make it work?
i assumed from prior experience that blue led means serial monitor so i tried to use arduino serial monitor to see activity but no luck

can you explain how to send the data? make work from this point?

ok wow i just got it to work i figgured the path problem for flash.bat but was getting unable to detect message
after the drag and drop i could detect and run flash.bat

flash.bat worked successfully

awesome thanks for help

if you get a chance to add to wiki and more discription of whst the path info is for editing

i dont like microsoft onedrive but have to live with it

also can you optionally connect to ground and 3.3 or at the servo 8 pin block on expansion board?
avoid having to connect to vcc and gnd adjacent to chip?

i would assume these pins are the same?

thanks to you i have 2 working boards now!

Hi ReptillonEP,

Since “blink” worked, I guess that means XIAO is not broken.
I have a few questions.

Which pins is a charger connected to?
Are a charger and USB cable connected at the same time?
Which pins is a Neopixel connected to?
Please answer with the pin name in the pinout diagram in the link below

  • By charger I mean connected through the USB-C input.
  • I have tried connecting the Neopixel to pins D10, D0, and D3.
  • The Neopixel is being powered through the XIAO’s ground pin and 3.3v pin (the pins near to D10).

XIAO’s 3.3V pin can only supply about 200mA, can Neopixel be used with less than 200mA?

It ran the strip when programming, but when I plugged in the strip to wall power, it no longer lit up, both when plugged into the wall and when plugged into my computer again.

How many LEDs are mounted on the strip?

However, I believe the issue does not lie with the LED’s, as the issue did not start until I plugged the XIAO via USB-C into a phone charging travel adapter that outputs 5 V and max 700mA.

What is the power supply when it was working properly?
XIAO’s 3.3V terminal can only supply 200mA to the strip, which is totally insufficient for 192 LEDs.