Seeeduino XIAO COM Port Problems

I am having no luck finding my Seeeduino XIAO when I plug it into the USB Port. No Port comes up in device manager, and no port comes up in the Arduino IDE.

Any Suggestions?

I have the same problem with The Seeeduino Lotus Cortext M0. It has the same SAMD21 processor. Simular to my Cortex board you can get your board in Boatloader mode (double press reset button), but this does not solve anything for me.

https://wiki.seeedstudio.com/Seeeduino-XIAO-by-Nanase/#bootloader-mode

Let me know if you find any solution!

Hi @blweaver, Did you installed the XIAO Additional board files? if yes , you can try to reset the board.

Reset

Sometimes the Seeeduino XIAO port may disappear when user programming process fails. we can solve this problem by the following operation:

  • Connect the Seeeduino XIAO to your computer.
  • Use tweezers or short lines to short the RST pins in the diagram twice.
  • The orange LED lights flicker on and light up.

At this point, the chip enters Bootloader mode and the burn port appears again. Because the samd21 chip has two partitions, one is the Bootloader and the other is the user program. The product will burn a bootloader code in the system memory when it leaves the factory. We can switch modes with a quick reset.

image

Src: https://wiki.seeedstudio.com/Seeeduino-XIAO/

Thank you.

This works for one of the boards the 3 others I have won’t go into bootloading mode:
The LED won’t light up

Any ideas how to get the board into Bootloader mode?

Yes, To enter Bootloader mode

Thanks again!

This works for only one of my boards. The others (3 pcs.) fail to get into Bootloader mode (LED is not starting to light up). I can’t believe they are irreversible damaged because they worked before ;-(

It happend after uploading simple Blink code (Arduino IDE)

I have a strong feeling they are ‘stuck’. Any other ideas to get them into bootloader Mode?

Hi everyone, I saw this and it looks identical to the issue I am having with the SAMD chips on Odyssey boards I just received. I thought I would add a link to that topic here. That way if a solution is found for one, it may be applicable to both. Odyssey x86j4105 ubuntu 20.4 no /dev/ttyACM0 and no seeeduino listed under lsusb.

Best,

Cameron

New XIAO. Arduino IDE. Installed Seeed board file. Selected XIAO board. No port visible. Reset, steady orange. Still no board visible. Help!

Can you see the device in the computer device Manager? Is a bad USB data cable ?

No. Cable is good and has complete set of conductors with continuity. Same on Win7 and Win10 machines. Have installed seeed board info and selected xiao. THank you for your reply.