Seeeduino V328 problems

Hi! I just got my Seeeduino today, and was excited to try it out. Unfortunately I get multiple errors (I have tested it on three different computers, one running Windows 7 (x86_64) and Linux (x86_64), one running Windows Server 2008 (x86_64) and another one running Windows XP (SP3, 32-bit).

On the first computer, running Windows 7, I get the following errors when trying to upload a sketch with the Arduino IDE:

avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

Which seems to be what many many others get too.

On Linux, I get the following:
avrdude: stk500_recv(): programmer is not responding

I managed to get one sketch uploaded (the Blink example) on Linux, but that was when I chose LilyPad w/ ATmega328 from the Arduino menu. After that, I haven’t got anything uploaded, not on Linux, not on Windows, not with Arduino Duemilanove w/ ATmega 328 selected from the IDE menu or with LilyPad w/ ATmega328. Whenever I try to upload a sketch, the RX light on the Seeeduino blinks three times. A few seconds later it blinks once, but I still get an error. The TX light isn’t blinking at all.

I have also tried this tutorial: … ex_en.html but avrdude doesn’t read my fuses properly:

avrdude.exe: BitBang OK
avrdude.exe: pin assign miso 3 sck 5 mosi 6 reset 7
avrdude.exe: drain OK

ft245r: bitclk 4800 -> ft baud 2400
avrdude.exe: ft245r_program_enable: failed
avrdude.exe: initialization failed, rc=-1
Double check connections and try again, or use -F to override
this check.

avrdude.exe done. Thank you.

Of course I have soldered the UART pinheader and connected it to the ISP connector by the diagram in this PDF: … eduino.pdf
If I add -F to the command line, it reads the fuses, but they’re not what they’re supposed to be. hFuse is 0xFF, lFuse is 0xFF and eFuse is 0x07. Lock bit is 0x3F. Writing the fuses doesn’t work, they’re back to the old values when avrdude does the verification. I haven’t tried to burn in a new bootloader due to these things failing.

What could be the problem, or is my Seeeduino just broken?

This sounds exactly like the problems I’m having with the Seeeduino 328 I received last week. The error messages are pretty much identical.

Not that I want to jump to conclusions, but is it possible the current batch of Seeeduino 328’s have a dud bootloader on them?

I just received a V328 today and I’m having problems uploading sketches too. The pin 13 and TX LEDs flash rapidly when the seeeduino is powered, and when uploading a sketch I get no errors, but the upload never completes.

I’m pretty sure it’s a board problem because I’ve had no issues with other seeeduinos and arduinos.

What can we do?

It’s a surprise to learn this! the process was the same as other batches, tested and visual inspected. We would need to identify the root cause, please help ship back by air mail to us for replacement, bill us for the freight please.

Hi Guys,
Exact same problem here… received it yesterday (20-11-2009)
The date on my v328 seeeduino is 06/23/2009
pin13 led and tx keep flashing. Sometimes after a while the tx leds stops flashing and it’s just pin13.
When I try uploading I see the reset led flash for a millisecond (barely noticeable)
but nothing happens.

Hopefully there’s a solution without shipping it back.
Or should I send it back straight away?


I have the same problems
How verify FT232RL parameters ? (speed and other ?)
Best regards

Hi Again,

I have fixed Mine!
I used an “UsbTinyISP” avr-programmer to replace the bootloader.
(I was lucky enough to have one)
Perhaps something went wrong in the fusing of this batch.

Thanks for the reply. What address should I send the Seeeduino to? Does it matter if I’ve already soldered the UART pin header on the Seeeduino?

Hmmm… on Windows 7 I don’t get an error (the upload just never completes) but on linux I get the error instantly.

I think I’ll buy a programmer and try and burn a new bootloader rather than waiting for my board to be shipped to and fro from China; especially since someone has already had success with this method.

I have also fixed mine with the USBtinyISP.
A quick description of the process:

  1. Make sure external power jumper is REMOVED from USBtinyISP, plug in USBtinyISP to board
  2. Plug in EXTERNAL power to the seeeduino, and plug in the USBtinyISP to USB
  3. Set the seeduino to external power via seeeduino slide switch (USB/EXT)
  4. FOR LINUX USERS: start the Arduino IDE as ROOT
    eg.: sudo ./arduino from your arduino directory
  5. From the arduino IDE, select Tools\Burn Bootloader\ w/USBtinyISP
  6. Be patient, takes a minute or two - red light (RST) near external power connector will stay lit solid for the entire operation


The same problem with my unit. Received today. It has the same date as Gepatto’s unit. (06/23/2009).
Uploading takes forever, tx led keeps flashing.

I managed to fix mine with a USBtinyISP also… if anyone lives near Boston and wants to borrow an ISP programmer let me know (although they’re cheap to buy and only take a few minutes to solder together… I got mine from Adafruit and had it shipped overnight; way faster than sending my seeeduino back to China!).

Did you check the fuses on the AVR before you used the USBtinyISP if they’d show the Duemilanove ones? I’d be interested if there’s an actual problem with the microcontrollers themselves.

same here. I had to burn bootloader (used AVRISP MKII) to get board to work

I have the same problem with a V328 that was shipped out on 10/22.

I burned a new copy of the bootloader via AVRDude and it now works fine. It definitely appears their current batch has problems with the bootloader.

However, I did notice that the fuses were set different from the factory vs. the 328 fuse settings at the bootloader burning walk-through (

  • hFuse was DF (instead of DA)
  • lFuse was FF (correct)
  • eFuse was 07 (instead of 05)

well today I did my plate.(29-10-2009)
I have the same problem as you.
the truth is that this is frustrating.
to see if I can solve.
from here would ask the lords of Seeedstudio take steps to prevent this happening again in future

I received mine a couple days ago. I cannot ship it back because I’ll be charged importation taxes from China again (200% the price of the board :astonished: )

I believe all this run went with problems. Does anybody know whether I can record the boot loader using parallel port programmer or not?

Pedro Paulo Jr

I can report similar problem - seeduino v328 06/23/2009. Verified blinking leds and forever upload/state issues. Sounds like the batch is dud.

Are there any software/wiring alternatives to buying a bootloader writer?

By the way: from the AVR-Writer description one should connect the ISP to the X3 pins. The X3 has been replaced with a UART interface on this board - how to connect etc?

:angry: I think Seeedstudio should post a fixa in their page. The risk of not doing it is it’s credibility