Seeeduino V328 problems

Okay, I’ve now gotten the d2xx macosx samples to work according to the online guide. It correctly communicates with the board. (from

Then, I’ve followed the instructions to build the serjtag-avrdude patch. It is done, but will not run with the extended avrdude.conf supplied by serjtag. Any tips? I’ve tried:

  • Using the serjtag binary avrdude.conf (complains about syntax error, but is really a missing programmer)
  • Using a combination of the existing m168,stk500,t2313 programmers with no avail

Please help…:slight_smile:

(Oh, and btw the seeduino 328 now only lights up PWR + RST when connected)

Okay, finally got avrdude+serjtag working, but here is the state for my board.

Seeduino v328 06/23/2009

Fuses as read by avrdude (in diecimila/m328p mode) - the number in parenteses is what the guide suggests to use:
efuse: 07 (05)
hfuse: ff (da)
lfuse: ff (ff)
lock: 3f (3f)

Attempting to set the fuses causes write errors in avrdude.

I finally got the 328 bootloader onto the board by force with avrdude, but since the fuses are wrong it does not seem to work yet. I’d really appreciate some pointers?

I finally managed to fix it.
I used the mode bitbang FT232RL
but the truth is I’m not happy with zero support of SeeedStudio
we’ll see in the future if I buy more here.
to me that they will have the boot of ATmega168.

After getting the bootloader written (but the fuses wrong), I somehow got the “Blink” example uploaded. To my amazement Arduino IDE said “upload done”. Wow - I was starting to get my hopes up, but then all subsequent attempts to upload fail with programmer not responding.

Hrmpf. Back to the drawing board.

Yes, this is exactly what happened to me. I got one sketch uploaded and none after that.

macguiwer: did you get the fuses set correctly?

avrdude complains to me when attempting to set fuses, and the ones I can set are set back to the previously mentioned values after reset.

Oh, and erase doesn’t work either.

I got it working using a parallel port programmer. But it sucks to receive a board with a defective bootloader.

I follow step by step this website … ex_en.html
just change the value of the fuser I put the correct
logically and also you put your correct hex
have tried to erase the chip and then change the fuses?
my board is to operate normally.
you can at least read the value of the fuser?

geocities ceased to exist.

I just provide the link and it works for me.
I am in Spain, Europe.
where are you?
if you have problem with acces to that page I can put it away and send by Email.

Guys, sorry for lacking response here! We will review this issue seriously, and work out a standard solution ASAP. Satisfaction are guaranteed as before, you may ask for replacement if the faulty Seeeduino is gating your project schedule!

Thanks as usual! :slight_smile:

Most of us had to assemble a parallel port cable and got around with great delay by this fault bootloader. You should offer a discount in the next purchase

Hi Guys,

Much sorry for the problem, we are inquiring the problem.
We will give you the solution in 2 days.


Hi guys,
We have inquired the ISSUE of the last batch Seeeduino_v328.
It is a bootloader ISSUE, Wrong fuse config.

Here is the way to fix bootloader by Seeeduino_V328 itself.
First please find the attached file including:
1).atmega328.hex(an original Arduino 328 bootloader);
2).avrdude.config (modified avrdude config file);
3).avrdude.exe (avrdude program);

1).Solder on the UART (2x3 pin header);
2).Connect as:
3).Direct decompression the attached file to path D:\Program Files;

Fix bootloader
1).Connect Seeeduino_v328 to PC via USB(Note just connect 1 FTDI device to PC);
2).open the FixSeeeduino_v328.pdf;
3).windows command: Start–>Run–>type “cmd”–>enter;
4).In command window, execute following command step by step, a brief explanation included in the zip file.

1 D: 2 cd D:\Program Files\FixSeeeduino_v328 3 avrdude -c SeeedStudio -P ft0 -p m328p -t -B 4800 3 erase 4 w efuse 0 0x05 5 w hfuse 0 0xda 6 w lfuse 0 0xff 7 quit 8 avrdude -c SeeedStudio -P ft0 -p m328p -U flash:w:atmega328.hex 9 avrdude -c SeeedStudio -P ft0 -p m328p -t 10 w lock 0 0x0f 11 d efuse 12 d hfuse 13 d lfuse 14 d lock 15 quit

Any problem please let us know.

FixSeeeduino_v328.rar (104 KB) (124 KB)

We should have response a lot earlier, sorry again.

Root cause: The latest Seeeduino shipped to you might have wrong fuse, which will cause bootloader sector get skipped. For the first time we upload test program via bootloader, it is all right. But if the device is repowered, the MCU does not go into bootloader anymore.


  1. Please refer to the quick fix by Bitbang mode as the last post from Albert
    if it is too much trouble,
  2. we are more than relieved to replace one for you.

We did serious testing to the Seeeduino shipped, [visual inspect -> program bootloader -> functional test of each pin -> package]. But we still need a complete process to cover the exceptions. The damage to our quality and your time is permanent. Please let us know if any assist needed. Sorry for the huge inconvenience brought!

Thanks for your support!

I did the fix and it works great! Thank you very much!

Now I can finally get to playing around with this thing, thanks again :slight_smile:

I just received 2 Seeeduino v328. Neither will complete a code upload.

Unfortunately these are for a project, a sound installation, that I am beginning next week and I don’t have the time to execute the solve offered. I’ll return the boards for replacement.


It could be fixed instantly following instruction above, if you need them urgently. Or, please send it to following address by air mail:

A1504 Shan Dong Mansion,
NanHai Ave. NanShan dist.
Shenzhen 518054 China
Pan, Hao
+86 755 29338658

Same to anybody needs replacement, we will refund the airmail cost and send replacement ASAP. Thanks!

Thanks for the info! Got mine working without any problems.

Hi, I have two boards with this problem. When I try to go through the steps I get an errormessage:
avrdude -c SeeedStudio -P ft0 -p m328p -t -B 4800

Message in dosbox:
avrdude: BitBang OK
avrdude: pin assign miso 3 sck 5 mosi 6 reset 7
avrdude: drain OK

ft245r: bitclk 4800 -> ft baud 2400
avrdude: AVR device initialized and ready to accept instructions

Reading | ################################################## | 100% 0.00s

avrdude: Device signature = 0x1e9406
avrdude: Expected signature for ATMEGA328P is 1E 95 0F
Double check chip, or use -F to override this check.

avrdude done. Thank you.

Why can’t AVR-dude recognize the atmega328? Can I override the check?
Does it matter what the positions of the three switches next to the usb-connector are?

Best regards,