Seeeduino Nano Not uploading in Arduino 2.0 IDE

I am trying to upload my first sketch to my Seeduino Nano using my Arduino 2.0 IDE. I have already associated the necessary website and downloaded the corresponding board library for the device. I am able to associate the correct board in the drop down menu. I read that it is best to associate it to a COM that is >=3, which I did.

My sketch compiles with no issue, but it will not upload. It says the following, “avrdude: ser_open(): can’t open device “\.\COM4”: Access is denied.”

I looked it up and saw that it was something to do with the COM being used for some other device, but I don’t for the life of me know what. I have previously used an Arduino Uno and a Seeed XIAO, both of which worked fine.

I have tried the following troubleshooting steps.

  • Restart IDE
  • Restart Computer
  • Change to COM3 (only other COM available)
  • Download another board package with other Seeed boards
  • Change USB ports

It’s weird though, because when I setup my Seeed XIAO it automatically opened up a COM15, which I can’t even access if I try. That board works completely fine…

Hello, I had the same problem you had, I tried to downgrade the arduino to 1.8 and was able to upload successfully

I was able to fix it while still using the 2.0.3 IDE version, but it was NOT straight forward at all.

I had to do the following:

  • Add a driver for the USB that the board uses (Cleared up my COM issue)
  • Add part of the missing file path that was not installed when adding in the board manager process. This was very tedious, but I realized that it was missing a few folders and bits of data, which I found on another message board.

It was a bit of a pain, but it all works now!