reTerminal bluetooth does not detect anything

I received my reTerminal back in August and have never been able to get the bluetooth module to detect anything (e.g. bluetooth speakers, bluetooth keyboard, my laptop’s bluetooth). Originally the wifi did not work as well, but after updating the reTerminal OS (the default image, just updated), the wifi worked. Since the wifi and bluetooth module are the same, I assumed it was more of a driver or OS issue and less of a hardware issue. However, after updating the OS again 2 days ago to the newest (again still using the default image, just updated), the bluetooth still will not detect anything. Has anyone else seen this issue? If so, any recommended resolutions? Thank you!
Quick edit: I did have the test devices (the speakers and keyboard) in pairing mode, and they were detected by other devices (e.g. my Raspberry Pi 4), so I know the peripheral devices’ bluetooth are working correctly.

I found a solution to this (my) issue. In some cases, reTerminal with Raspberry Pi OS (I am using the 32-bit 2021-09-14 version that Seeed Studio provides through their wiki) does not seem to properly start up bluetooth when booting. The GUI “Add Device” option under the bluetooth dropdown will not show anything. However, you can find devices by running the following commands in the command terminal:
bluetoothctl
scan on

Here is what I have to do to get bluetooth devices to connect:

  1. each time I boot the reTerminal, I have to open the command terminal and run “bluetoothctl”. That will enable me to connect devices that have already been paired.
  2. If I wish to pair a new device, I run “bluetoothctl”, “scan on”, then “scan off” through the command terminal. At that point, the GUI “Add Device” option will show devices and enable me to pair and connect them.

I followed the guide here (Raspberry Pi Compute Module 4 question with Bluetooth Add Device... - Raspberry Pi Forums) to get this working.

It looks like there is an issue with the default image provided that causes bluetooth to exhibit this behavior on some reTerminals, so I hope the image can be updated to fix this. But, this is a fix for people who have the same issue I was facing.