reTerminal - blank screen after flashing OS ... again!

Yes, I have fallen down the same nasty hole, and cannot find my way back out.

I received my reTerminal before Christmas and have roamed around the Net ever since, trying all the guides and scripts and forums - right through Christmas and New Year - and now, frankly, I wish I had never bought it.

My goal was to use this device as a Home Assistant terminal, using Lakshan’s script from the Getting Started wiki. Getting Started with HA on reTerminal. This script failed at Step 14 when HA rejected the shipped Raspbian as an “un-authorised” OS. (The “fix-broken-install” didn’t work).

Since then I have tried many combinations of HA with Raspbian OS, trying with and without Docker containers, but without success. Most of my interaction has been via VNC, with the screen displayed through HDMI.

But things went downhill when I stepped through the guide: FAQ #2: How can I flash Raspberry Pi OS which is originally shipped with reTerminal?. I used the 32-bit 2022-07-21-Raspbian-reTerminal. NB. It is labelled as 2022-07-21, but it actually unpacks as 2022-06-19. Re-flashing the OS killed the LCD and multiple attempts to flash OS images, followed by re-installing the reTerminal drivers have failed. Install reTerminal drivers after flashing.

I have not tried re-flashing the STM32 since the reTerminal is very new, and was working. Q1: Update the STM32 firmware. The other buttons etc. seem to work, and i2cdetect seems to show the correct address for the newer DSI chip (0x56).


I have noticed that the reTerminal demo tool shows the LCD backlight slider is always at 0 (but increasing it to max has no effect). I guess this might be related? Other data for my current installation from the reTerminal demo script is:

I have now abandoned all hope of getting HA and Raspbian to play nicely together on reTerminal and instead will use another RPi4 to run HAOS. But I do hope I can at least use my reTerminal as a remote HMI kiosk.

I am no expert and would greatly appreciate any guidance/suggestions/scripts that might help me get the LCD working again. Thanks in advance.

Cheers, Stephen

[PS. Shouldn’t there be a reTerminal sub-category in this forum?]

See your case is that the screen driver is not loaded properly, so the i2c address of the screen will be 0x56, which is the normal case.

Suggest you check the config.txt has dtoverlay=reTerminal and not logged out

Hi @nengyu. Thanks for your reply. Yes, I agree that the i2c addressing looks correct with the i2c address showing up as 0x56 as is correct for the new DSI driver chip (as per my paste of the i2cdetect printout) rather than 0x45 for the older chip.

However, I can’t spot anything wrong in the config.txt file either (please see my paste below). It looks to me like all the recent additional scripts have been called, including:


What would really help me would be a guide or script(s) that would reset my system to factory new condition. Something in my setup is apparently not getting reset when I flash the OS followed by installing the overlays per my original post. But I don’t have enough experience with Linux or the Pi to know what else to do.

Cheers, Stephen

# For more options and information see
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border

# uncomment to force a console size. By default it will be display's size minus
# overscan.

# uncomment if hdmi display is not detected and composite is being output

# uncomment to force a specific HDMI mode (this will force VGA)

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display

# uncomment for composite PAL

#uncomment to overclock the arm. 700 MHz is the default.

# Uncomment some or all of these to enable the optional hardware interfaces

# Uncomment this to enable infrared communication.

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)

# Automatically load overlays for detected cameras

# Automatically load overlays for detected DSI displays

# Enable DRM VC4 V3D driver

# Disable compensation for displays with overscan

# Enable host mode on the 2711 built-in XHCI USB controller.
# This line should be removed if the legacy DWC2 controller is required
# (e.g. for USB device mode) or if USB support is not required.


# Run as fast as firmware / board allows


This screen driver i2c address is 0x56 no problem, but under normal circumstances is replaced by UU, if the display 0x56 instead of UU, indicating that the device is not occupied by the driver, I think you can try the method provided by this wiki

Thanks @nengyu. I did not appreciate the point about the 0x56 meaning driver not successfully loaded.

Yes, your first link is to the same guide that I linked as having done in my original post. Your second link is to re-flashing the STM32 chip, which I have referenced as not having done since it is hard to imagine how it might have been corrupted. But I guess this is now worth trying, since nothing else seems to be working. I will give it a go.

Thanks again. Cheers, Stephen

@nengyu Thanks again. Your suggestion to re-flash the STM32 has worked and I not have my LCD operating again. I admit that I am surprised … it just seems strange that it became corrupted - unless it was the drivers that needed to be upgraded. I’m really not sure what part of the process set things back to right.

Regardless, thanks again for your very good guidance that did the job. Cheers, Stephen.